Jump to content

Vostro 200 USB flash drive advice


bill888
 Share

Recommended Posts

hi, I'm new to hackintosh, but I have dabbled with Niresh's Maverick and Yosemite running on my old Vostro 200.  However, I thought I would try a 'clean' install of Maverick as a simple exercise to learn more, and to see if I can resolve the shutdown/sleep/wake issue.

 

To cut a long story short, the instructions contained in this locked thread served up by Google, could do with being updated.

 

https://osxlatitude.com/index.php?/topic/2032-dell-vostro-200-snow-leopardlionmountain-lionmavericksyosemite/

 

I was also puzzled why my Vostro would freeze at the Dell splash screen when trying to use my newly created MyHack USB installer.  Eventually I stumbled across the thread quoted below, and realised that the Vostro 200 POST doesn't tolerate certain large capacity USB flash drives.  

 

I was using a 16GB Kingston Data Traveller G2.  But I also had same issue when I inserted a HP 32GB flash drive which was formatted FAT32 and contained only data files. ie. the problem does not seem to be restricted to using GUID instead of MBR.

 

Problem was resolved by using a smaller 8GB Kingston Data Traveller drive.

 

I also found these later Maverick install instructions by Hervé to be more helpful:

https://osxlatitude.com/index.php?/topic/6627-vostro-200-cannot-install/?p=39310

 

 

Is it possible to update the locked "Dell Vostro 200 - Snow Leopard/Lion/Mountain Lion/Mavericks/Yosemite" thread quoted above with this information about the USB flash drives, and link to the newer instructions which doesn't use EDP7?

 

fwiw, here is my hardware setup is:

Factory BIOS v1.0.16 with SLIC 2.1 mod only.

Asus Radeon 5450 512MB gfx card

VL805/812 based USB3 card

Some fine tuning is required.

 

 

 

 

 
Link to comment
Share on other sites

  • Administrators

I will not update my research thread/pseudo guide with the info you wish to add about USB keys simply because it's not universal at all. Not all USB keys are equal and I was able to use several 8Go and 16Go USB keys on the Vostro (and other computers) without issues. I have too experienced issue with larger 32Go keys that I found incompatible with GPT scheme whilst others were Ok. That's for that.

 

As for updating my thread, well my Vostro OS X HDD died several years ago and since I was hardly using it, I've never bothered to replace it. I turn that old desktop on maybe once or twice a year to print something from the Win7 installation. Same with the even older Precision 670. I keep them for symbolic reasons and only use laptops these days.

Link to comment
Share on other sites

Thank you for your comments.  

 

fwiw, installing Maverick using 8GB usb flash drive and MyHack was successful as reported by others. Sadly, I couldn't fix the wake from sleep issue. I can only speculate the DSDT contained in the Vostro 200 bootpack is perhaps incompatible with my hardware configuration (original firmware, VIA USB3 card, and Asus 5450 gfx - which also required the Radeon 5450 and X3000 kexts to be modified to fix the flickering graphics).

 

Next, I tried using Clover to install Yosemite.  I got past the selecting Language only to discover Disk Utility could not see the internal SATA drives! (I recall choosing default 64 bit SATA driver option in Clover configuration).  Perhaps the driver is not compatible with RAID mode in my stock 1.0.16 firmware with SLIC mod.

 

I then used Enoch Chameleon installer.  To my surprise, the Vostro froze at the Dell startup screen when using GUID on my Kingston 8GB USB flash drive - which previously worked perfectly with Myhack and Mavericks.  I then used MBR which permitted the Vostro to boot past the Dell startup screen, but encountered a different problem booting the Installer.  :(   (Unfortunately, I didn't write down the error message, but in hindsight, it may have been possible to fix the issue.)

 

By this time I was becoming frustrated, so I abandoned using slow USB flash drives, and chose to use an old and faster 160GB SATA hard drive to create a hard drive based Enoch Yosemite installer and remembering to add the kexts and missing kernel.  Yosemite is now installed and seems to be working but only while the hard drive installer was attached. 

 

Eventually, I had to boot from another hard drive containing and older (Niresh) hackintosh installation, to run Enoch to fix what looked like a missing bootloader on the newly installed Yosemite hard drive. I'm not sure if this step would have been necessary if I was able to use an Enoch USB installer.

 

 

 
Update:  I learned sleep doesn't work with Yosemite as reported by others when using a Chameleon bootloader.  A recurring issue was when intentionally forcing the PC into sleep, it always reset the BIOS!  The 'Patched_10.7_AppleRTC.kext' from the Vostro 200 boot pack doesn't seem to work and is probably not intended for use with Yosemite.  
 
I used information found here to patch a copy of the original AppleRTC from /System/Library/Extensions after applying combo update 10.10.5, and to reinstall my patched version using Kext Utility.
 
 
(I actually used a Hex Editor to open AppleRTC, find '75 2E 0F B6', and replaced '75' with 'EB')
 
I later installed the Experimental BIOS for Vostro 200, and observed it no longer seems to reset the BIOS when the dsdt.aml and my patched AppleRTC files are both present. (Update: Same behaviour using original firmware)   I can live without 'sleep' function.
 
The VoodooHDA audio driver included in the boot pack also do not seem to work with Yosemite.  Newer v2.8.7/2.8.8 drivers works fine.
 
This is all a useful learning experience so may try installing El Capitan next.  It may also encourage me to buy a better PC/laptop which is more hackintosh-compatible.
Link to comment
Share on other sites

 Share

×
×
  • Create New...