Jump to content

[Solved] E5420: display+LAN+audio issues with Yosemite and El Capitan


amthb0
 Share

Recommended Posts

Hi everyone, 

I have an E5420, BIOS A14, i5-2520m, 4Gx2 RAM, 1600*900 screen.

I followed this to install El Capitan, at first, the system kept rebooting like this. I found a workable DSDT from this, finally, I can see the installation welcome screen. but it only displays half part. 

I've tried Clover r3556 r3577 r3949, couldn't get it fixed. 

Could anyone please give some help? Thank you. 

 

This is El Capitan installation screen. [This issue has been fixed by using DSDT in #4 post. Thanks, Jake.]

post-103144-0-88584500-1487003016_thumb.jpg
 

Btw, actually, the issue also happened in Yosemite in a different phase

I followed this one to install Yosemite, Yosemite installation screen is normal, but there's an issue in Post-installation Welcome screen. It only displayed half screen. I had to image where the buttons are inside the invisible half and installed the Graphic driver. Then the display came back to normal. The DSDT for Yosemite is in post #14.

 

This is Yosemite post-installation Welcome screen. [Follow #19 post to fix this issue. Thanks, Hervé]

post-103144-0-34389400-1487307961_thumb.jpg

Link to comment
Share on other sites

Thank you, Jake.
 
Forgot to put the link of the workable DSDT, it is https://osxlatitude.com/index.php?/topic/9095-solved-e5420-i5-sandybridge-el-capitan-problem-booting-into-installer/page-2&do=findComment&comment=61109.
 
I use the config.plist files from your guide https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/&do=findComment&comment=54632, for ElCapitan and Sierra. I upload them as well.

 

 

(CORRECTION: I used Clover files for Sierra in r3949, need to replace them with El Capitan files for installing El Capitan.)

post-103144-0-52181900-1487038631_thumb.png

post-103144-0-65227900-1487038633_thumb.png

clover.zip

Link to comment
Share on other sites

Hi Jake, 
I got some new issue during the installation and after. Please take a look. 
Erasing the partition or re-partition the drive, it was very very slow, it took too long to finish, sometimes my drive even disappeared from the Disk Utility. This didn't happen during Yosemite installation. Was AHCI driver missing during the installation? 
 
I tried Intel 520 240G and OCZ ARC100 240G, both got the same issue. The clover files are in #3 post, they are from your clover guide. https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/ 
 
Eventually, the installation finished. But failed to boot the OS. The error message during booting OS is attached. 
 
Thank you. 
 
 

post-103144-0-77326800-1487308673_thumb.jpg

Link to comment
Share on other sites

I tried r3949, when erasing the drive, it's very slow, after maybe 2-3 minutes, my drive(OCZ ARC100) disappeared from the disk utility. Erasing should finish within 10 seconds. This also happened in r3556 vs intel 520.  Something might be wrong somewhere. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...