Jump to content

Asus z77 Extreme 4: unable to boot myHack Mavericks installer


Recommended Posts

Hi, I used Myhack a few years ago and had no problems with installation. I recently tried to duel boot my pc, but I am unable to even get to the installer. It would say something like 'cannot find root, waiting' so I booted up in verbose mode and found the installation was getting stuck on this;


"AppleUSBEHCI::Found a transaction which hasn't moved in 5 seconds on bus 0x1a, timing out!


address = 3 



I've tried everything so far, different bootflags, moving the usb stick to different ports, unplugged all usb ports apart from the keyboard etc.  I can't work it out, I've spent the past 2 hours on google trying to find an answer and nobody knows! Any help would be greatly appreciated.  


Mavericks, with Myhack


Bootflags = PciRoot=1, USBBUSfix=yes, -x, -f, -v, -s, arch = 1386


BIOS         =  Pci - legacy, ERP disabled, HPET enabled, ACHI mode


System -  I5 3570k, 

                 Asus z77 Extreme 4                    

                 Gtx 970 

                 16GB cosair ram

                 Samsung 850 Evo

                 Focusrite Scarlett

Link to comment
Share on other sites

  • Administrators

You won't get anywhere with old Chameleon option arch=i386 on anything younger than Lion! All subsequent OS X/maxOS versions are 64bit only...


If your USB installer does not seem to load anything any longer after a short while, try unplugging/replugging it. I'd leave PciRoot at default value to begin with (i.e. 0) unless you know that it is set to something different in DSDT.


Re: USB ports, you could try USBLegacyOff=Yes instead of USBBusFix=Yes which enables all 3 x USB fixes:

  1. EHCIacquire
  2. UHCIreset
  3. USBLegacyOff


Remember to rigorously follow the syntax of the options as all are syntax sensitive. If in doubt about a particular option, type ? at Chameleon prompt/delay bar. For instance, it's USBBusFix not USBBUSfix or arch=i386 not arch=1386...

Link to comment
Share on other sites

Thanks for your reply. I was mostly copying other peoples' bootflags in hope they would work. I removed them all and am now just using -v -s and USBLegacyOff=yes. 


I tried to reset the USB stick but was prompted with a message along the line of 'missing media'. 

Unfortunately i'm still getting the same message, I tried a Yosemite installation too and was still met with the same message. I also realised there was a warning above stating "IOBluetoothHCIcontroller Search for transport event handler - Missing bluetooth control transport" then the 'Appleusbchi' error comes up and then messages loop.  I'm not sure if they're related or not. 

I found some topics on the IOBluetooth problem, so I will research and try the fixes. If they don't solve the problem I will return to pick your brains. ~

Thanks, Tom

Link to comment
Share on other sites

  • Administrators

-s flag will not boot your system since it's for single-user mode, i.e. some step by step special boot mode you only use when you try to repair the system after doing something that broke it...


You want to use -f -v flags to boot without cache and in verbose mode.

Link to comment
Share on other sites

  • Create New...