Jump to content

[SOLVED] E7450 Sierra (Nvidia) garbled login screen


viking1304
 Share

Recommended Posts

I have E7450 (with 840m). BIOS version is A15. Latest Sierra install form app store.

I followed Jake Lo's guides:
https://osxlatitude.com/index.php?/topic/8514-dell-latitude-e7450-clover-uefi-only/
https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/

I used EFI_v4119.zip generic EFI, replaced some files with those from E7450_840m.zip as per instructions here
https://osxlatitude.com/index.php?/topic/9740-solved-dell-latitude-e7450-intel-5500-with-discrete-nvidia-840m/?p=69173

Patched both 0x15b and 0x15c, changed SATA mode to AHCI.

Booting goes fine, but unfortunately initial screen where I should select language is garbled and unusable.

 

Any advice? What I am doing (did) wrong?

 

Link to comment
Share on other sites

Thank you for quick reply Jake.

 

EDIT:

 

I need to edit my complete post now in order to avoid possible confusion.

 

You posted two different archives with same name and I downloaded both of them. I guess I somehow managed to add wrong one to EFI and I was getting service exited with abnormal code 1 errors

 

20170730_134939.jpg
 

So I compared files from E7450_A15_Disabled-840m.zip and E7450_840m.zip and noticed few differences in config.plist, but most noticeable difference that I noticed was (not) using NewWay

				<key>NewWay_80000000</key>
				<true/>
I also noticed that some files in ACPI/patched folder are not same. Those two files are different:
DSDT.aml
SSDT-11.aml

So I tired to replace files that I mentioned, but I still had same problem.
 
Then I tried again with EFI_4128.zip and E7450_A15_Disabled-840m.zip. Replaced Boot and Clover folders on USB and tried again.

It boots, but I have garbled screen again.
 
20170730_143759.jpg

 

I guess I need to check everything again, since I need to be sure that this time I did everything properly.
 

btw. I knew that mentioned files were update only, so I tried to make bootpack myself before I posted here. I combined files from E7450_Sierra.zip, E7450_840m.zip and RehabMan-FakePCIID-2017-0527.zip, and then add those to EFI_v4119.zip, but obviously I messed something up.  :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...