Jump to content

Keronei

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Keronei

  • Rank
    Private

Recent Profile Visitors

119 profile views
  1. and one more, the ambient light sensor, if I can also get that...posibly it will be better.
  2. I'll just remove the Intel card altogether because it has no job. Initially, I didn't merge the files. I kept a backup of all the clover folder and deleted everything in /patched and placed the ones you sent, did same for config.plist and did as instructed for the kexts(excluding the Broadcom ones because I don't have any Broadcom chip). I will patch the DSDT with the what you've provided and report progress. I can't predict how long it will take but will ultimately report back. Thanks again.
  3. There's the Internal Intel wifi card, which has a Bluetooth that is USB based, that seems to be the only networked USB device. It doesn't work either, although I configured it in UIAC with connector type 255 (internal). I use the external mouse & keyboard as well. What are the specific configurations which makes the touchpad recognised(from your config pack) ? maybe I can just work with that for now(with the previous configuration) until I manage to get the DSDT patch detected.
  4. Looks like there's no difference with the new configuration. I have disabled wake on USB/LAN/WWAN but wake on USB type c is enabled on BIOS. The UIAC.aml, I did generate from my system...only the ports I required is what I enabled, it has 16 ports when injectcted. Some like the smart card reader(USB based), I did disconnected it from the board because it was overheating and I don't think if I'll use it soon.
  5. Gave a try on the bootpack. Touch pad works and recognized as mouse - better than previous Display seems to have recognized the ambient light sensor because it has the auto-adjust brightness option, however, VGA doesn't work, when I plug in, everything seems to freeze and have to force shut down - I have been using the external display without any issues. It still doesn't sleep, although it seems to have no issues with power button now but still around the same issue, gives below reason: 2020-04-13 21:04:44.306877+0300 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: XDCI Other items like sound works pretty well like before, but the audio device is not recognized as PCI in system info(which I have no problem as long as there's audio output) - it also doesn't play the charger-connected sound during startup but I have no issue with that. Possibly I'll have to merge the setup to find the best match, I'll appreciate any further suggestions
  6. As per my look, but from the boot log, the DSDT doesnt load. What could be the issue? because possibly it could have given me a step if the patch had gone through
  7. I have four patches -- PNLF for graphics, USBX for USB power management, EC for implanting fake Embedded controller & UIAC for USB ports - but are separate from main DSDT. I did added a patch for power in PBTN return method of _PWR to prevent the instant wake(I thought it could prevent the PBTN) but the DSDT could not be loaded, looks like I missed something because the DSDT was never loaded. It actually had a bunch of warnings but there were no errors. am attaching a snap of some of the warnings from the patch attempt and the DSDT itself. DSDT.dsl.zip
  8. Hello there, I have made an installation on a latitude 5580 and to this extent I don't seem to figure out why I'm not getting the touchpad to work at all. After opening the board, it seems to have an Alps Dualpoint touchpad. I have also been hinted that the connection is I2C based and have disabled OS X drivers from attaching to it and installed VoodooI2C and VoodooI2CHID but to this extent I haven't seen any good response. Another issue that I need help is the sleep. When I go to apple menu then sleep(or idles for specified time), it prepares to sleep(assumably) and then turns of display for about 15 secs but when the power button breaths the first time, it wakes the system, when I queried the wake reason, I get the following: 2020-04-09 12:52:09.906346+0300 localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: PBTN XDCI (User) Please shed some light, Thanks in advance. debug_22164.zip
×
×
  • Create New...