Jump to content

hannibal1969

Members
  • Content Count

    19
  • Joined

  • Last visited

Community Reputation

0 Neutral

About hannibal1969

  • Rank
    Private First Class
  1. https://osxlatitude.com/forums/topic/12930-dell-optiplex-7040-micro-need-help/?do=findComment&comment=98270 Is there no solution for wake from sleep? I have a Optiplex 3040 SFF which is almost the same and have the same issue and don't want to add a external GPU because I don't have room and I like to keep these systems as clean as possible. Any idea what the issue is?
  2. Yes I was already doubting. I have now a config working but it only works with a bogus fake-id and inject intel. Normally with Lilu and WEG I was expecting it would work out of the box for a HD4600. I updated bios from 2.07 -> 2.77 and I thing prealloc of DVMT has been changed. I'm stuck now. I had a Optiplex 9020 based on same cpu which was working perfectly so I thought a HP ProDesk would be good choice too.
  3. I have a question about a HP ProDesk 600G1 SFF. I have it already running smoothly with Mojave (currently updating to Catalina) but I have only one problem. When I reboot or shutdown it causes a panic. It is not visible. It's caused on the end of the shutdown or reboot procedure. While booting in verbose or just after entering the GUI its telling me it was rebooted by a panic. I don't know if it is also resetting the BIOS. I don't think so but I think it has something to do with it. At insalymac there is a elitedesk 800g1 which is almost the same system somebody tells something about a RTCMemoryFixup.kext which had to be added but I tried and no success. Any idea how to fix this?
  4. It was already there. I think it has to do with loading windows reboot osx then no audio. If I do a real shutdown before starting OSX from windows the audio is initialized correctly and I hear audio from the speakers as it should. I will keep you informed if this is really the case. But for now, I think it is.
  5. Hi, After applying the changes and a reboot there was no difference. However, after a shutdown, the audio appears to be okay. I knew in the past there where specific options in Clover to reset HDA after sleep but I don't know if they will help. P.S. what is the difference between putting kexts in Clover / Kexts / Other and Library / Extensions?
  6. mmmm after a reboot it stopped again. So audio over speakers is not always working. Headphone is always working though.
  7. Here you go my friend. *** THATS STRANGE IT LOOKS THAT THE AUDIO IS WORKING *** So stop investigation for now. Thanks Jake for setting up my precision as Wonderfull hack ... well its ugly but it does the job debug_18526.zip
  8. Hi, Well I placed all files in place. Repaired permissions of L/E rebuild the caches etc. The audio loads fine however the internal speakers don't give sound. If I plugin a headset the audio is fine not the speaker output. I'm sure this is just a small adjustment which has to made however I don't know what to do. Thanks in advance!
  9. Hi Guys. I have a Precision M6800 where I removed the internal m6100 ati discrete video card. This was needed to enable the laptop using internal LVDS which is connected to the internal HD4600. I have a fully working hack now. There are two issues I still have. I have to use VoodooHDA for audio ATM but I hope you guys can help me how to get it enabled without the VoodooHDA kext. Sometimes iTunes crashes. Especially when I start it the first time. After that it looks stable. I think it has to do with the VoodooHDA.kext. Im not 100% sure about this. When I switch over to Wifi it looks much more stable??? I tried IntelMausiEthernet.kext & FakePCIID_Intel_GbX.kext but sometimes it crashes with both kexts. Let hopes VoodooHDA is causing the trouble. I tried the AppleALC, HDAEnabler and Lillu kexts along with my current kexts (without voodoohda of course) but then it panics. Is there someone who can look into my clover content with my IOReg Dump? I removed as many kexts / drivers as possible. See attached files. Thanks is really appriciated! Edit. The crashing from iTunes looks to be fixed to me. I added Lilu with Shiki together with bootarg "shikigva=1". I'm still interested in how to replace VoodooHDA with AppleALC. m6800 efi content.zip Han’s MacBook Pro.ioreg.zip
  10. I see that you have a file in "com.apple.kext.caches" \ Startup \ excludedkextalert.plist I don't have that one. Whats in there ? Where do you have clover installed? I see in clover config "<key>DefaultVolume</key> <string>yosemite 1To</string>" I see in L / E BJUsbLoad.kext and CIJUSBLoad.kext can you tell me why installed ? I see in S / L / E extra kexts as : AppleHDA_ALC292.kext, BrcmFirmwareRepo.kext, BrcmPatchRam2.kext, FakePCIID_HD4600_HD4400.kext, FakePCIID_XHCIMux.kext but where are CodecCommander.kext, DisableTurboBoostBattery.kext and EAPDFix.kext? These 3 and also AppleHDA_ALC292.kext should be in L / E according to the guide. FakePCIID.kext must be in EFI / Clover / Kexts / with FakePCIID_HD4600_HD4400.kext but moving that one to S / L / E might result in a difference for me. Are using just 1 memory slot ? Which DSDT.aml did you use? Do you have additional SSDT's as well other then the CPU SSDT? Cheers and I really appreciate your help ! Thanks !
  11. really really appreciated your effort. Can you put the EFI content on a "we share" / "dropbox" or OneDrive please? So you have installed El Capitan on mSATA in the mSata slot not in the SATA slot with mSata bracket ? Thanks !
  12. Thanks for your reply, Which bios version ? Specific other settings changed in Bios instead of Bios Defaults -> SATA to AHCI and enable Legacy Mode too ? What do you use on mSata OSX or windows ? What do you use on SATA OSX or windows ? Can you share your /S/L/Caches/com.apple.kext.caches content ? Can you share your clover config? Can you share your EFI folder ? Which kexts did you added to L/E? Which kexts did you added to S / L / E ? Thank you !
  13. mmm i'm considering selling my Dell E7440 for a real mac. Going back to 10.9.x is too much back IMO. I will try to do a legacy install and see if that will help.
  14. Yes I had that value too. I decided to change it to 0x3 but it didn't do the trick. I even found out now that when I shutdown the e7440 and try repeating booting it will boot after 5 - 6 times so I'm really out of options and ideas. Somebody at Insanelymac told me that he had this laptop too and he was telling me that the e7440 had tons of issues. He also stated that maybe go for just 10.10.2 and don't update was an option. Can someone clarifies his statement why 10.10.2 is a good option? He told me that with 10.10.2 the video card would work OOB...
  15. Thank you for your reply, Indeed I don't believe this either. I removed msata and I isolated the problem to the following which acknowledge the kextcache problem. I need to do in single user / kextcache -system-prelinked-kernel / kextcache -system-caches. After that I can reboot as many times as I like. However when i shutdown the system completely i need to starter the whole process again. So it looks when I choose shutdown something regarding the kextcaching mechanism triggers something to be unable to boot the next time. I found out that there is a difference in the exit procedure shutdown or reboot. When you choose to shutdown or reboot the following is happening: Sandbox: rm(500) System Policy: allow(0) file-write-unlink /private/tmp/NVRAM/nvram.plist Sandbox: bash(501) System Policy: allow(0) file-write-create /private/tmp/NVRAM/nvram.plist Sandbox: chflags(502) System Policy: allow(0) file-write-flags /private/tmp/NVRAM/nvram.plist Can this be the issue? What about the SIP settings? Now I use : <key>RtVariables</key> <dict> <key>BooterConfig</key> <string>0x28</string> <key>CsrActiveConfig</key> <string>0x3</string> and CSR status gives : Dell-Latitude-E7440-OSX:~ admin$ sudo csrutil status Password: System Integrity Protection status: enabled (Custom Configuration). Configuration: Apple Internal: disabled Kext Signing: disabled Filesystem Protections: disabled Debugging Restrictions: enabled DTrace Restrictions: enabled NVRAM Protections: enabled
×
×
  • Create New...