Jump to content

Vmonheros

Members
  • Content Count

    13
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Vmonheros

  • Rank
    Private First Class
  1. Hi Leon, I just donate 50 euros (as we're in Europe, no fees). I would prefer that you "use" it to go to another forum software, however, I understand that It might required a lot of investments from the team and that can be a "bad" option. So, even if I voted for changing the forum software, to be honest, I'm OK also if you decided to just go to pay for copyright removal as what is important for me it is that the community will continue to be here. To the community, think that the team donate a lot of their time for this site, so we cannot "force" them to go to another forum software. Fred.
  2. You can try other Frame buffer values. 0x0a160000 for example. Look about what Pike explains about that. Depending of Frame buffer values, your display ports are no the same. There is a script also to patch Frame buffer and learn a bit more (https://pikeralpha.wordpress.com/2014/09/16/appleintelframebufferazul-sh-v3-0-beta/). And note. There is no VGA port on Mac... For me, the 0x0a160000 is the one closer to what we have on mobile (with a display port). Up to you to find the best one for you with Desktop Haswell. Please, do a special Clover USB key to do your test (and so modify config.plist). For Haswell (I copy the information from InsanelyMac) & adapt (check where is 0x0a160000 here ) { 0x00,0x00,0x06,0x04 }, // 0 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - mobile GT1 { 0x00,0x00,0x06,0x0c }, // 1 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - SDV mobile GT1 { 0x00,0x00,0x16,0x04 }, // 2 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - mobile GT2 { 0x00,0x00,0x16,0x0a }, // 3 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT mobile GT2 { 0x00,0x00,0x16,0x0c }, // 4 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - SDV mobile GT2 { 0x00,0x00,0x26,0x04 }, // 5 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - mobile GT3 { 0x00,0x00,0x26,0x0a }, // 6 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT mobile GT3 { 0x00,0x00,0x26,0x0c }, // 7 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - SDV mobile GT3 { 0x00,0x00,0x26,0x0d }, // 8 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - CRW mobile GT3 { 0x02,0x00,0x16,0x04 }, // 9 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 1, Ports: 1, FBMem: 1 - mobile GT2 { 0x03,0x00,0x22,0x0d }, // 10 "AAPL,ig-platform-id" HD5000 //FB: 0MB, Pipes: 0, Ports: 0, FBMem: 0 - CRW Desktop GT3 { 0x05,0x00,0x26,0x0a }, // 11 "AAPL,ig-platform-id" HD5000 //FB: 32MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT mobile GT3 { 0x06,0x00,0x26,0x0a }, // 12 "AAPL,ig-platform-id" HD5000 //FB: 32MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT mobile GT3 { 0x07,0x00,0x26,0x0d }, // 13 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 4, FBMem: 3 - CRW mobile GT3 { 0x08,0x00,0x26,0x0a }, // 14 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT mobile GT3 { 0x08,0x00,0x2e,0x0a }, // 15 "AAPL,ig-platform-id" HD5000 //FB: 64MB, Pipes: 3, Ports: 3, FBMem: 3 - ULT reserved GT3
  3. Hi. For video, we will see later. At present time, I'm sure that you don't have QE/CI. Go to system, and check the video card. I'm sure it will say that you have 7 MB of VRAM => means that frame buffer is here, but not HD5000 driver. It will be some work to have a desktop HD4600 works... Look here http://www.insanelymac.com/forum/topic/298591-intel-hd-4600-qeci-yosemite/. You can use Clover for that, inject fake ID in the & also patch the kext, have a look here https://pikeralpha.wordpress.com/2014/09/10/experimental-bin-patch-for-hd4600-mobile-gt2/. You will have to adapt a bit, as you've got a desktop HD4600, not a mobile one. However, I'm sure some people discuss about that somewhere inside these threads. For audio, for a first try, go with VoodooHDA. It will be the easier way. There is an install package at InsanelyMac http://www.insanelymac.com/forum/files/file/324-voodoohda/. VoodooHDA don't work if you have it inside Clover folder kext, so please, install it in S/L/E. And reboot your cache. (with Kext Utility that works very well). You can have a try later on Apple HDA patching http://www.tonycrapx86.com/audio/143757-audio-realtek-alc-applehda-guide.html For USB3, for sure it will work first. But did you check if USB2 works after sleep ? For you LAN, you will have to install some additional Kext. No way with DSDT. Qualcomm® Atheros Killer E2201 is here http://www.insanelymac.com/forum/topic/300056-solution-for-qualcomm-atheros-ar816x-ar817x-and-killer-e220x/. Again, install it in S/L/E Intel® GbE LAN http://www.insanelymac.com/forum/topic/219114-intele1000e-kext-82566mm-82577lm-etc/, in S/L/E In general, do not install anything in Clover kext folders after install (if you want to do test, go with a clover usb stick). Please, install all in S/L/E. Note to moderators : I hope there is no issue to crosslink to other forums ?
  4. Hi. Your installation is not finished. Yosemite is in 2 time, first copy files to disk (OS X Install Data) and after, the real installation. So after the reboot, reboot on your Clover usb key (that might be your OS X insulation key) and chose again OS X install (please, look at all the "disks" presented by Clover at this time, you will find the right one ). I'm sorry, my laptop is on RMA, so I cannot do the test again. I will do that when it come back. So, no, your issue is not linked to the DSDT patching. And yes, It occurs sometimes also to me that during reboot, Laptop don't see correctly the USB key . No need to clean your CMOS, just stop and reboot your computer. Note that I never have the issue with hard disk on SATA, so it might be some USB detection issue. On gigabyte card, how do you force UEFI to boot to one device, when you configured that the default boot is on hard drive? On ASUS, just need to press "ESC" to decide what will be my boot drive (Hard disk, USB etc...) How did you create your OS X install key ? P.S.: system take a very long time to reboot because certainly some USB patch need to be done, and you're in USB for installation. Also, this USB garbage can remain after the reboot (so sometimes, you don't see the USB key...). A clean stop and start the laptop clean that.
  5. I corrected your config.plist. This one is full of "crap". You use the config.plist of another user that you modified with Clover Configurator ? It is a useful tool, but always look inside the generated plist . Look at your old one, you've got I don't know how many things inside the plist for DSDT patching that remain active. It can cause issues. Try this one (it has minimum DSDT patch, HPET, DTGP, MCHC and darwin). If it works, we will have a look later at USB & others. Note that I think it's better to edit its DSDT & SSDT, but to begin, why not use Clover for that. config.plist.zip
  6. What is your Clover version ? Did you tried the "slide=xxx" as boot arg ? xxx might be 0 (by default) or more. Some people have success with 100.
  7. Hi, I've got a quick look at your Clover config. 1) You don't need to put the SSDT generate by Pike script in ACPI\patched because you yet generated P & C states with Clover in your plist configuration (and you can enable from C2 to C7) 2) If you don't inject any frame buffer in the graphic section, it will never work. As you've got an HD4600 graphic card inside your processor, and it's a desktop one, it will be a bit more complicated with Yosemite (as the HD4600 mobile ID is not anymore inside the frame buffer kext plist & also that will have to bin patch HD5000 kext to inject your native desktop HD4600 ID to have QE/CI). Sorry to link you to another forum, but look here http://www.insanelymac.com/forum/topic/298591-intel-hd-4600-qeci-yosemite. But at least, inject one value in ig-plateform-id, just to ensure that it will force the frame buffer to load (but you will not have accelerate QE/CI), try 0x0a260006 for example. 3) Remove Asus AICPUPM, you've got an Haswell processor, it's not for you... You do the right thing (for Haswell processor) with KernelPM. And also, no need for Kernel CPU, it is to "fake" some CPUID, not need for your Haswell processor and Yosemite 4) In ACPI, leave DSDT name empty, as you have no DSDT.aml in your ACPI\Patched. Remove also the Halt Enabler option. ​I don't check the other patchs you enable, I'm not sure that you need so much. In general, begin with minimum (HPET & MCHC => enable this one and might be LPC (it depends of the LPC ID of your Haswell chipset)).
  8. Hi, thanks for your response. The 2 kexts from you I use is the Elan Touchpad and the BTFirmwareuploader one (last version also). I enable backlight. Inside Plist, I didn't do a lot of configuration on the touchpad part (apart for the backlight + Palm), and a bit more inside the keyboard part (enable backlight, configure/adapt Fn key, use ISO keyboard). Reboot happens when using mouse (no gesture at all, just using "default" mouse pointer). Saddly, at the reboot time, I've got no kernel panic, just direct reboot. Just before reboot, I've got mouse freeze, and reboot. I checked inside the kernel.log, and saw nothing... If there is some option to move your kext in a more verbose mode, it will be a pleasure. I will use now your "new" kext version of today, and keep you informed. I will contact you with PM for my Ioreg, my DSDT+SSDTs and also with the Plist I edited in the kext. I use clover as boot loader with few Kexts (the yours, FakeSMC+Plugins from Kozlek, ACPIBatteryManager from Zprood, ACPIBacklight from Rehabman, GenericXHCI from Rehabman and VoodooHDA 2.8.5 from Anv). All kexts in last version (I didn't use enhanced ACPIBatteryManager from Rehabman as I've got some issue with it - I yet filled a bug for it).
  9. Hi, I havent got any of these kexts . I installed just Elantech one. For the keyboard, everything is fine with configuration of the one embedded inside Elantech kext (backlight etc...), so why do we need the Asus one (I can understand for people that don't have an Elantech touchpad, but when you have one) ? Same question for the EAPD fix (I didn't use it, Ive haven't got a Realtek codec and furthermore I use VoodooHda) that is also inside the Elantech kext (in the last versions)... Thanks for the Palm information. For the reboot, it is linked to the mouse (and not the keyboard) I think. In fact, at one time my mouse freeze, and just after, reboot. Update : I tested again, reboot is always here... Sad, because this version is an heavy improvement for pointer in my case!
  10. Hi, With the last 3.8.5 version, I've got constant computer reboot. It can take up to 5 minutes, sometimes less than 20 seconds... So bad as I felt that mouse precision is better, I've got no more mouse jump when I want to close a window. But I also encounter issues with scrolling (more link to the need pression I have to put on the touchpad to have this one working - certainly link to your new palm pressure option and need some ajustement in config.plist from me). Sadly, I cannot test more due to reboot, so I switched back to 3.8 release. I've got an Asus UX32LN, with Elan V4 and software buttons. If you can explain me how to help you (and me) on this topic, with certainly some debug session, it will be a pleasure !!!
  11. Hi, just to inform you that your kext works well on the last Zenbook UX32LN (Haswell Core I5-4200U, Nvidia Optimus disable in DSDT). However, one question (someone asked also about some times ago) : there is no possibility to enable bezel when you use Fn Keyboard Backlight key ? The other ones work well (screen and sound) but it is perhaps because we use "native" Apple kext for that ?
  12. Hi, sorry for my english !!! My question is that your Elan Touchpad driver hosts keyboard driver. This "internal" Elan Touchpad keyboard driver can be configured for an Asus keymap. So, what is the added value of the Fn Hotkey Driver for Asus Netbooks if we compare it with Elan kext configured for Asus keymap ?
  13. Hi, Excuse my silly question, but what is the added value of this kext as there is also inside your Elan Touchpad kext configuration for Asus Keyboard (and others)? I'm a bit lost here, and doesn't find the response anywhere. Thanks.
×
×
  • Create New...