Jump to content

johnstray2001

Members
  • Posts

    26
  • Joined

  • Last visited

  • Days Won

    1

johnstray2001 last won the day on October 6 2016

johnstray2001 had the most liked content!

Contact Methods

  • Website URL
    https://www.johnstray.id.au/
  • Twitter
    johnstray13

Profile Information

  • Gender
    Male
  • Location
    Alice Springs, NT, Australia

johnstray2001's Achievements

Corporal

Corporal (4/17)

1

Reputation

  1. I just tried manually setting the DNS server in Network Settings, but that didn't seem to make any difference. The log still shows: sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>] rcvd [LCP TermReq id=0x1]
  2. FYI: Here is the PPP log from a connection Mon Feb 13 11:12:30 2017 : Apple Base Script.ccl Version 3.3 Mon Feb 13 11:12:30 2017 : CCLWrite : AT\13 Mon Feb 13 11:12:30 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:12:30 2017 : Initializing device: AT&FE0Q0V1 Mon Feb 13 11:12:30 2017 : CCLWrite : AT&FE0Q0V1\13 Mon Feb 13 11:12:30 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:12:30 2017 : Initializing PDP context: AT+CGDCONT=1,"IP","internet" Mon Feb 13 11:12:30 2017 : CCLWrite : AT+CGDCONT=1,"IP","internet"\13 Mon Feb 13 11:12:30 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:12:30 2017 : Dialing: ATD*99***1# Mon Feb 13 11:12:30 2017 : CCLWrite : ATD*99***1#\13 Mon Feb 13 11:12:30 2017 : Waiting for connection Mon Feb 13 11:12:31 2017 : CCLMatched : CONNECT\13\10 Mon Feb 13 11:12:31 2017 : Connection established Mon Feb 13 11:12:34 2017 : CCLExit: 0 Mon Feb 13 11:12:34 2017 : Serial connection established. Mon Feb 13 11:12:34 2017 : using link 0 Mon Feb 13 11:12:34 2017 : Using interface ppp0 Mon Feb 13 11:12:34 2017 : Connect: ppp0 <--> /dev/cu.wwan Mon Feb 13 11:12:35 2017 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x614daf3c> <pcomp> <accomp>] Mon Feb 13 11:12:35 2017 : rcvd [LCP ConfReq id=0x3 <auth chap MD5> <accomp> <pcomp> <mru 1500> <asyncmap 0x0> <magic 0x8a60d27d>] Mon Feb 13 11:12:35 2017 : lcp_reqci: returning CONFACK. Mon Feb 13 11:12:35 2017 : sent [LCP ConfAck id=0x3 <auth chap MD5> <accomp> <pcomp> <mru 1500> <asyncmap 0x0> <magic 0x8a60d27d>] Mon Feb 13 11:12:35 2017 : rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x614daf3c> <pcomp> <accomp>] Mon Feb 13 11:12:35 2017 : rcvd [CHAP Challenge id=0x0 <7edf2cf58afb187156d7c4ade27330a92ecf5c653aeb48e106c7f41d92636019debf8cd5eadb7851b6b7248d425390898eafbc459acba8c166>, name = "Kermit"] Mon Feb 13 11:12:35 2017 : sent [CHAP Response id=0x0 <ac4085652a3b5eb3dff33770b25f6420>, name = "guest"] Mon Feb 13 11:12:35 2017 : rcvd [CHAP Success id=0x0 "Congratulations!"] Mon Feb 13 11:12:35 2017 : CHAP authentication succeeded: Congratulations! Mon Feb 13 11:12:35 2017 : sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>] Mon Feb 13 11:12:35 2017 : rcvd [LCP TermReq id=0x1] Mon Feb 13 11:12:35 2017 : LCP terminated by peer Mon Feb 13 11:12:35 2017 : sent [LCP TermAck id=0x1] Mon Feb 13 11:12:38 2017 : Connection terminated. Mon Feb 13 11:12:38 2017 : CCLWrite : +++ Mon Feb 13 11:12:46 2017 : CCLWrite : ATH\13 Mon Feb 13 11:12:46 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:12:48 2017 : CCLWrite : AT&F\13 Mon Feb 13 11:12:48 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:12:48 2017 : CCLExit: 0 Mon Feb 13 11:12:48 2017 : Serial link disconnected. Mon Feb 13 11:13:40 2017 : publish_entry SCDSet() failed: Success! Mon Feb 13 11:13:40 2017 : publish_entry SCDSet() failed: Success! Mon Feb 13 11:13:42 2017 : Apple Base Script.ccl Version 3.3 Mon Feb 13 11:13:42 2017 : CCLWrite : AT\13 Mon Feb 13 11:13:42 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:13:42 2017 : Initializing device: AT&FE0Q0V1 Mon Feb 13 11:13:42 2017 : CCLWrite : AT&FE0Q0V1\13 Mon Feb 13 11:13:42 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:13:42 2017 : Initializing PDP context: AT+CGDCONT=1,"IP","internet" Mon Feb 13 11:13:42 2017 : CCLWrite : AT+CGDCONT=1,"IP","internet"\13 Mon Feb 13 11:13:42 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:13:42 2017 : Dialing: ATD*99***1# Mon Feb 13 11:13:42 2017 : CCLWrite : ATD*99***1#\13 Mon Feb 13 11:13:42 2017 : Waiting for connection Mon Feb 13 11:13:43 2017 : CCLMatched : CONNECT\13\10 Mon Feb 13 11:13:43 2017 : Connection established Mon Feb 13 11:13:46 2017 : CCLExit: 0 Mon Feb 13 11:13:46 2017 : Serial connection established. Mon Feb 13 11:13:46 2017 : using link 0 Mon Feb 13 11:13:46 2017 : Using interface ppp0 Mon Feb 13 11:13:46 2017 : Connect: ppp0 <--> /dev/cu.wwan Mon Feb 13 11:13:47 2017 : sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x44f760d0> <pcomp> <accomp>] Mon Feb 13 11:13:47 2017 : rcvd [LCP ConfReq id=0x3 <auth chap MD5> <accomp> <pcomp> <mru 1500> <asyncmap 0x0> <magic 0x71c1093f>] Mon Feb 13 11:13:47 2017 : No auth is possible Mon Feb 13 11:13:47 2017 : lcp_reqci: returning CONFREJ. Mon Feb 13 11:13:47 2017 : sent [LCP ConfRej id=0x3 <auth chap MD5>] Mon Feb 13 11:13:47 2017 : rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x44f760d0> <pcomp> <accomp>] Mon Feb 13 11:13:47 2017 : rcvd [LCP ConfReq id=0x4 <accomp> <pcomp> <mru 1500> <asyncmap 0x0> <magic 0x71c1093f>] Mon Feb 13 11:13:47 2017 : lcp_reqci: returning CONFACK. Mon Feb 13 11:13:47 2017 : sent [LCP ConfAck id=0x4 <accomp> <pcomp> <mru 1500> <asyncmap 0x0> <magic 0x71c1093f>] Mon Feb 13 11:13:47 2017 : sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>] Mon Feb 13 11:13:47 2017 : rcvd [LCP TermReq id=0x1] Mon Feb 13 11:13:47 2017 : LCP terminated by peer Mon Feb 13 11:13:47 2017 : sent [LCP TermAck id=0x1] Mon Feb 13 11:13:50 2017 : Connection terminated. Mon Feb 13 11:13:50 2017 : CCLWrite : +++ Mon Feb 13 11:13:58 2017 : CCLWrite : ATH\13 Mon Feb 13 11:13:58 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:14:00 2017 : CCLWrite : AT&F\13 Mon Feb 13 11:14:00 2017 : CCLMatched : OK\13\10 Mon Feb 13 11:14:00 2017 : CCLExit: 0 Mon Feb 13 11:14:00 2017 : Serial link disconnected.
  3. Contacted my provider today, and they were very helpful... not... They say that because it's working under Windows and Ubuntu, that it is a compatibility issue with macOS and there is nothing they can do about it. So maybe it's something in the PPP negotiation script (if there is one). I haven't been able to figure out how to log the PPP data under windows 10 or under ubuntu 16.10 so that I can see if there are any differences (any suggestions? Google only has links for windows 7 [didn't work with win10] and for older versions of Ubuntu [again didn't work])
  4. @InsanelyDeepak: G'day mate! You've successfully helped me to create an AppleHDA patch for my laptop in the past and for that I am very grateful. I'm doing another hack for a mate of mine but have not been able to get the audio working. I've tried using AppleALC and all the layout-ids for the codec, and i've also tried using your cloverHDA, both without success. I was wondering if you would mind helping me once again? The computer in question this time around is an Acer Aspire Z3-605-UR22 All-In-One. Even though it's a desktop, it has mobile hardware. It's using Realtek ALC269VC for audio. It has the following physical ports: Internal Microphone Internal Stereo Speakers Front Headphone/Microphone combo jack (4-pin 1/8" iPhone style) Rear Stereo Line Out ( 3-pin 1/8" Jack ) [Line Level - No Amp] Rear Stereo Line In (3-pin 1/8" Jack) I have attached to this message a copy of the codec_dump.txt for it. If we can create a successful patch, I'd like to be able to add it to AppleALC so that I can keep it in the Clover kexts folder and /S/L/E remains vanilla (I find this to be the best approach). If you need any more information, please let me know. Thank-you in advance for any assistance you can provide. Yours truely, John. codec_dump.txt
  5. So, after some further reading of the system logs I think I've identified where the problem may lay: During PPP negotiation, my device requests an IP address, to which the provider responds with a terminate request. I doubt this would be an account issue as it works perfectly under Windows 10 and Ubuntu 16.10. Should I be contacting my provider about this, or is this something that can be fixed in MacOS (eg. configs somewhere)??
  6. I'm with Optus Australia. Their APN details are here. After reading that page, I discovered that the APN i was using was wrong. So, tried again with the correct one, but still no such luck.
  7. I've actually come across that post before, but I couldn't figure out how to export the profile under Windows. How do you do that? I have Windows 10 on it. A google search on how to do it was fruitless.
  8. I've tried connecting through all of them, except en1. All result in basically the same results in the console.
  9. I have attached screenshots of the various settings related to this. To inject my device into CellPhoneHelper.kext, I actually created an Codeless Injector kext which is loaded by Clover. Following is the content of the Info.plist file: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"> <plist version="1.0"> <dict> <key>CFBundleDevelopmentRegion</key> <string>English</string> <key>CFBundleGetInfoString</key> <string>Ericsson H5321gw 3G Wireless WAN Device Driver</string> <key>CFBundleIdentifier</key> <string>com.ericsson.h5321gw</string> <key>CFBundleInfoDictionaryVersion</key> <string>6.0</string> <key>CFBundleName</key> <string>Ericsson H5321gw 3G Wireless WAN Device Driver</string> <key>CFBundlePackageType</key> <string>KEXT</string> <key>CFBundleVersion</key> <string>1.0.0</string> <key>CFBundleSignature</key> <string>????</string> <key>IOKitPersonalities</key> <dict> <key>0x0BDB/0x1926 Ericsson H5321 gw</key> <dict> <key>CFBundleIdentifier</key> <string>com.apple.driver.AppleUSBHostMergeProperties</string> <key>IOClass</key> <string>AppleUSBHostMergeProperties</string> <key>IOProviderClass</key> <string>IOUSBHostDevice</string> <key>IOProviderMergeProperties</key> <dict> <key>DeviceModemOverrides</key> <dict> <key>AccessPointName</key> <string>connect</string> <key>ConnectionPersonality</key> <string>Sony Ericsson GPRS</string> <key>ConnectionScript</key> <string>Generic GPRS.ccl</string> <key>DeviceContextID</key> <string>1</string> <key>DeviceModel</key> <string>GPRS (GSM/3G)</string> <key>Device Vendor</key> <string>Sony Ericsson</string> </dict> <key>DevicePPPOverrides</key> <dict> <key>LCPMTU</key> <integer>1450</integer> </dict> <key>InfoCommands</key> <dict> <key>ATCommands</key> <dict> <key>DirectoryNumber</key> <string>+cnum</string> <key>IMEI</key> <string>+cgsn</string> <key>IMSI</key> <string>+cimi</string> <key>Manufacturer</key> <string>+cgmi</string> <key>Model</key> <string>+cgmm</string> <key>ModemSW</key> <string>+cgmr</string> </dict> <key>HiddenProperties</key> <dict> <key>CommandPortBaseName</key> <string>wwan</string> <key>ControlPortBaseName</key> <string>wwan</string> <key>DataPortBaseName</key> <string>wwan</string> <key>InterfaceDriver</key> <string>AppleUSBCDC</string> <key>StatusType</key> <string>CellPhoneGSM</string> </dict> </dict> <key>Initializing</key> <true/> <key>InterfaceMapping</key> <dict> <key>2</key> <dict> <key>name</key> <string>wwan</string> </dict> </dict> <key>WWAN</key> <true/> </dict> <key>bcdDevice</key> <integer>0</integer> <key>idProduct</key> <integer>6438</integer> <key>idVendor</key> <integer>3035</integer> </dict> </dict> <key>OSBundleLibraries</key> <dict> <key>com.apple.driver.AppleUSBHostMergeProperties</key> <string>1.0</string> <key>com.apple.iokit.IOUSBHostFamily</key> <string>1.0.1</string> <key>com.apple.kpi.iokit</key> <string>8.0</string> <key>com.apple.kpi.libkern</key> <string>9.0.0</string> </dict> </dict> </plist> This was created based on information in another post here. The F5521gw is virtually the same card as this one, with the only difference being that the F is the Full-height mPCI version where as the H is the Half-height version. From the information I have found; This device has these interfaces: - H5321 gw Mobile Broadband Modem - H5321 gw Mobile Broadband Data Modem - H5321 gw Mobile Broadband GPS Port - H5321 gw Mobile Broadband Device Management - H5321 gw Mobile Broadband USIM Port IORegistryEditor shows this device as having 10 interfaces? IOReg dump attached. You'll find it under [email protected] -> [email protected] -> H5321 [email protected] ThinkBook.ioreg.zip
  10. My APN settings are definitely correct. They work under Windows and Ubuntu. APN: connect UN: <blank> PW: <blank>
  11. I have an Ericsson H5321gw 3G Wireless WWAN device in my laptop that I'd like to get working, but I am in need of some help. So far, I have successfully got the device to appear as a wwan device by patching CellPhoneHelper.kext with the correct idVendor, idProduct, etc.. I setup the correct apn for my service in network settings, "connect", tried both the Generic and Sony Ericsson profiles. However, I have not been able to connect yet. The console is reporting errors from pppd; "LCP: timeout sending Config-Requests", which then results in the connection disconnecting again. Is anyone able to help me solve this problem so that I can successfully connect? Thanks in advance for your help. It will be greatly appreciated. PS: This device works perfectly when used under both Windows 7/8.1/10 and Ubuntu 15.04/16.10. Here is the output from my console:
  12. This one worked perfectly! Thank-you so much for all the help you have provided. It is greatly appreciated.
  13. Here is the results from the Codec-Info.command This was done while AppleALC.kext was in place with clover and the stock AppleHDA in S/L/E/ Codec-Info.zip
  14. That AppleALC you posted didn't work. No devices showed up in System Preferences > Sound > Output/Input, however, they did show up in System Information > Audio EDIT: The cloverHDA method also failed with the same results. Issue posted at GitHub here.
×
×
  • Create New...