Jump to content

[SOLVED] Sierra on E5550 - No audio, camera, bluetooth, etc


TexasBear1
 Share

Recommended Posts

I was finally able to get Sierra running on my E5550, but some problems remain. 

 

Working: Graphics, battery indicator, Ethernet

Not working: Audio, Bluetooth, Camera, Card reader

 

I followed Jake Lo's guide, but wasn't able to get up and running that way. I had to hack my way through every step it seems. I used EFI_4200.zip and the E5550_A15_Disable_GT820M.zip bootpack. I've copied kext files to Clover and to LE, ran the chmod/chown and cache rebuild. I copied the config.plist from the bootpack download section-by-section into my working file. I finally tracked down the item that seems to be the issue. If I include ACPI\SSDT\DropOem = YES then I am not able to boot. Booting starts, but mid-way through the progress bar, I receive the O- symbol. I am not even sure if that has anything to do with my issue, but that is the only thing that I haven't completed all the way from the guide.

 

I have attached my config file and can send you any other data that you want to see. Any help would be greatly appreciated! I hope I haven't missed something dumb. :-)

config.plist.zip

Link to comment
Share on other sites

  • Moderators

Check the Display tab in the BIOS. Does it have an Optimus option?

Boot to Clover GUI, hit the F4 key. Wait a second and then boot into OSX

Mount EFI partition, use EFI Mounterv3 found in the Clover guide.

Compress and attach /EFI/Clover/ACPI/Origin folder here

 

Launch DPCIManager https://sourceforge.net/projects/dpcimanager/

Grab screenshot of Status and PCI List , attach or post it here

 

Launch IOReg IORegistryExplorer_v2.1.zip

Save it, compress and attach it here

 

With those info, I'll be able to patch your files specific to your system.

Is your BIOS A15?

Link to comment
Share on other sites

Jake, this did the trick! I was still not able to simply replace the EFI/Clover folder with the bootpack files and config, but through trial and error I finally came to a point where the boot completes and everything is working. 

 

Dell Latitude E5550

macOS Sierra 10.12.6

Working:

Intel HD 5500 Graphics w/QE - tested internal display, HDMI output, all working (did not test VGA)

Charge/battery/sleep/wake - all working, including power management functionality

Audio - tested internal speakers, HDMI output, all working (didn't test headphone jack)

Bluetooth - tested iPhone hotspot, working (but throughput slower than iMac)

Webcam - tested with FaceTime

SD card reader - tested with SDXC

Wifi - current card will never work so I will either buy a USB wifi or find an internal replacement card (not sure if that would work)

 

I will work on the keyboard setup later so I can get hotkeys working (volume already works). I notice that there is no brightness slider in the Displays preference pane. I'm assuming brightness is controlled by the keyboard only?

 

Overall, this setup is very fluid. Booting takes longer than a real MacBook, but once boot completes then the performance is very equivalent to a real Mac.

 

Jake, I really appreciate your assistance, and all the work you have put into developing and maintaining the bootpack files. Let me know if there is anything I can do for you (further testing, etc).

 

Thanks again!

Link to comment
Share on other sites

  • Moderators

Brightness slider should be working. Did you follow the post Installation?

Copying the kexts from /EFI/Clover/kexts/Other/LE to /Library/Extensions, repair permission and rebuild cache

For Brightness Fn key working, see the post install of my E7450 guide

 

Go with a replacement internal wifi...DW1560 or DW1830

Link to comment
Share on other sites

 Share

×
×
  • Create New...