Jump to content

Sierra - Dell T5600 - UEFI


vdv
 Share

Recommended Posts

Hi,

 

just purchased a "new" toy: Dell T5600 (used)

2 x Sandy Bridge EP Xeon E5-2690 @2.9GHz (Turbo boost to 3.8GHz)

32GB RAM 1333MHz

2 x 500 GB SSD SAMSUNG EVO

1 x Asus Matrix GTX 980 (looking for the second one)

 

I've been able to install and boot with USB (legacy), but I'm having hard time to boot from SSD as UEFI.

 

I configured Clover as follow (from here: https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/)

  • Install for UEFI booting only
  • Install Clover in the ESP
  • Drivers64UEFI\OsxAptioFixDrv-64
  • Install RC scripts on target volume
  • Install Clover Preference Pane 

Problem is that at boot the system doesn't see the disc (no boot disc). If I boot with USB there is no problem.

 

If I look in the BIOS, under UEFI setting, no UEFI boot path is select (and I don't know what to select).

 

I'm almost sure that if I would install as Legacy it will work.

I want to install as UEFI cause I will have Win10 as well.

 

Any suggestion is highly appreciated.

 

Side notes:

 

System seems to work very well except some random allocating error (to be fixed, I'll ask later)

DSDT gives 0 error (there are patches to be applied but I will ask later).

 

USB3 works with generic patch.

Sleep seems to work for other people  (I'll check)

 

I have to check about SAS integrated controller (not sure if enabled from BIOS).

 

Thanks

Link to comment
Share on other sites

It worked! Thanks! On the beginning Bios was not showing me the path. I copied Cloverx64.efi on root and renamed shellx64.efi. I pointed it and the boot went fine. After that bios showed me the full path you recommend. Strange. But worked.

 

Unfortunately I played a bit too much with clover now. Fresh reinstall needed. Anyhow boot issue solved. Let me know if you want to close it as solved or if I can go ahead with other questions.

Link to comment
Share on other sites

Well: I took inspiration for kext to use and dsdt from other forum (http://www.insanelymac.com/forum/topic/325921-sierra-10126-su-dell-precision-t5600/). Points I would need help:

 

SMBIOS - If I try to use 6.1, I have black screen problem. I'm currently using 14.2. Can I use 14.2 to configure SSDT in the right way? My aim is to have the correct Power management.

I tried a couple of patches for 6.1 black screen but no luck (Nviditagraphycfixup.kext still in my kext folder)

This is the first step to Power management. T5600 fans are noisy.

 

SOUND - Sound usually work with this method https://github.com/vit9696/AppleALC/wiki/Supported-codecs

When I try to modify SMBIOS to 6.1 (and bring back to 14.2 cause of black screen) sound desn't work anymore.

If I update clover and copy kext back no sound. Not sure what is wrong.

The same problem with sound happen if, from a fresh install, I would install HWSensor (to monitor CPU) no sound and no ethernet. No way to have them back.

EDIT: Sound seems solved. Downloaded fresh apple ALC an now is fine.

 

BOOT - If I use USB, clover boot loader start with no problem. If I use HD, clover boot loader doesn't start automatically. I must press enter or arrows and it will work. Maybe wrong setting in config.plist

 

I already made 6 fresh install and every time small errors I can't fix back.

 

p.s

not able to attach DSDT or config.plist 

Link to comment
Share on other sites

  • Moderators

You must compress the file before attaching using the More Reply Options on the lower right.

Yes, you should be able to generate SSDT with SMBIOS iMac 14,2

If you set the Config file with timeout and Default Boot Volume (under Boot) to the name of your OS X (case sensitive, so must be exact), it should boot automatically.

If you have to arrow to the selection, then you could go to the BIOS and set Clover to the top as the primary boot. If you don't have Clover as a boot option, then you could add it and move it to the top.

Link to comment
Share on other sites

Thanks for reply. 

 

Sorry for being unclear. When I tried to upload the file, it doesn't work (spinning double arrow for 20 minutes than blank fiend under "attach file")

I thought problem was related to the "Advanced Uploader". I try to select "Basic Uploader" but nothing change. I'll try with different line (maybe I have an upload limit).

Edit - uploading config and dsdt only works. Problem is on my line for upload.

 

Referring to Default Boot Volume, I crosschecked and it is correct.

I'm using the same config.plist both in USB stick and SSD. In SSD I set the right default boot volume (I tried also last booted but no changes).

 

With I boot with USB (Legacy) I receive kind of "boot_6", than clover boot

With I boot with SSD (UEFI) a black screen. I press some key, than clover boot. 

Please have a look to my config.

 

Bios setting are correct (was beginning of my post).

I created Clover pointing at /EFI/Clover/CLOVERx64.efi

Clover is in the top (otherwise Windows will boot first)

 

Referring to SSDT, I'm also trying with 5.1 (which is closer to 6.1).

DV 2.zip

Link to comment
Share on other sites

I did a few progress. With Legacy everything works. 

 

I'm now facing a bigger problem.

 

There are 2 SATA controllers on mobo.

 

C600/X79 - 6 Port SATA AHCI (unfortunately only 2 ports are available) - Id 1D02

C602 - 4 Port SATA - 4 ports are available - Id 1D6B

 

Unfortunately those 4 ports of C602 are not working OOB. I'm trying to play around but not success.

 

I can see the controller in DPCI manager and in Ioreg, but connected disc are not working. Any suggestion?

Link to comment
Share on other sites

 Share

×
×
  • Create New...