Jump to content

E7450 New installation and/or updating to HS 10.13.2 fail


acquarius.13
 Share

Recommended Posts

1. There was some issue with APFS and SSD trim on hacks. Recommended solution was to disable SSD trim or to use HFS+. I have no idea if that still applies or not. Personally I am using HFS+ because I am constantly using Clonezilla to backup and restore images of my partitions in order to safely play with my system and to be able to revert it quickly to perfectly working state.

 

 

2. Jake's bootpack contains all kexts that you need.

 

3. A bunch of warnings and assertion failures, even a long delay between RAM disk initialization and mounting of existing partitions is perfectly normal. After you generate SSDT.aml in post-install steps, your system will boot much faster and with less warnings (most of them are perfectly safe to ignore).

 

If you want to use APFS be sure that your EFI/CLOVER/drivers64UEFI folder contains apfs.efi.

 
I advice you to use Jake's Generic EFI folder EFI_4359.zip and Bootpack for your system, since all needed files are there.
Link to comment
Share on other sites

  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

Hi everybody!

 

As described on my signature, I successfully updated my E7450 to High Sierra (10.13.2), keeping the HFS+ file system, in order to avoid any problem still present for APFS and hackintosh.

 

I used the USB media update method which worked basically immediately (after a couple of reboots). 

 

I want to thank you everybody for support and suggestions, in particular Jake Lo.

 

One (hope so) final question: in this moment I'm able to use HWMonitor and sensors and I see a difference between macOS battery percentage and HWMonitor battery percentage.

 

Are you able to explain this issue?

 

Is there any fix?

 

You can find a picture in attachment.

 

Thanks again a lot

 

Marco

 

Link to comment
Share on other sites

Currently I'm using my old config.plist (from El Capitan) with many on-the-fly patches and a way to use iMessage/Continuity/Handoff. I forgot to put that boot flag and now the values are perfectly synced.

 

About my old config.plist, are there some patches/etc. that can be deleted? 

 

Thanks Jake

 

Link to comment
Share on other sites

  • Moderators

If you're using AppleALC + Lilu.kext for audio, then you could remove all the AppleHDA patches.

Also can remove SecondStagePatch 10.12 patch, as it's noted, it's for 10.12.

All AirPortBrcm4360 - PCI Error # can be remove

FVCO - wireless 10.12 can be remove as well.

Link to comment
Share on other sites

I removed the suggested on-the-fly patches and I tried to "sync" your config.plist to mine but I see that there are some differences that I don't completely understand. Is there any other suggestions to improve the config.plist?

 

Small update on battery status: charging the laptop takes the issue back out..

 

Link to comment
Share on other sites

im on a e7450 with a usb drive containing the boot pack in the efi folder, latest clover, using apfs.efi hfsplus.efi and 10.13.2 installer on the main partition.

 

i cannot format my drive to apfs, only hfs+.

sometimes drive utility shows i have no free space and fails to erase/partition unless i select the drive itself and not the volumes.

 

after video initialization screen goes blank until i close my screen and re-open it.

 

after the installer copies the needed files to the drive and reboots, it tells me osinstaller.pkg is missing or corrupt and says mac os can’t be installed.

 

would you please advise me on what to change?

am i missing something?

Link to comment
Share on other sites

 Share


×
×
  • Create New...