Jump to content

7280 i5 HD520 ALC256


karterilla
 Share

Recommended Posts

Hello I'm trying to install HS on a Latitude 7280 with an I5-2300, ALC256 sound and an Alps I2C TP.

I've been able to boot Clover (4411) HD 520 RehabMan config (even with a strange yellow&black striped square  and not the cylinder apple icon), bu no way for sound, but most then all no trackpad ad all even if configured as a simple mouse.

I'm using an external mouse.

Keyboard is working with VoodooPS2.

 

For TP

Following this guide (https://voodooi2c.github.io/#index) I'm getting always this the error in logs:

(kernel) VoodooI2CControllerDriver::pci8086,9d60 Unknown Synopsys component type: 0xffffffff

Which make me thinks this Alps it is not supported by I2C kext.

 

BIOS is 1.6.5.

 

Any idea for TP or sound.

 

I'm enclosing the debug as per black.dragon74 tool problem reporting generator.

 

Any clue welcomed.

Thanx

Link to comment
Share on other sites

WOW this I great... tank you so much.

 

Almost everything is working.

 

Audio Input, no Mic, but Out OK even on headphones

TP as mouse but this is a giant step aheads compare to nothing...

Need to work on keyboard layout since there is some misplaced keys (not an US keyboard layout)

 

I'm going to try HDMI output: any clue here?

 

Thanks again great, great job.

Link to comment
Share on other sites

OK thank you will do this in the following days and send you IOReg output.

 

Another glitch this more important: waking from sleep make half of the screen weird (take a look at the screenshoot) and after a couple of minutes freezes the laptop.

Either on batteries or plugged.

 

I'm trying also to understand why Mic In it not working while output it is OK.

 

Thanx for your time

post-93222-0-70621500-1521362893_thumb.jpg

Link to comment
Share on other sites

Hello injecting EDID breaks I2C TP: it stop working if I do insert the extracted string as per link.

I've tried different config in clover with no luck.

I will stay for now without it and never putting to sleep the laptop.

The sooner I got a working thing will try back

 

On MIC side tried different injected number still no luck.

Need to working on this more deeply.

 

Thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...