Jump to content
liemhatang

How to change DVMT for Dell System

Recommended Posts

Is there an updated guide for this @Jake Lo??

 

The word doc in the archive seems incomplete.

 

Also, I get an error when I try using Universal IFR Extractor. Says "Protocol: Unknown" instead of "Protocol:UEFI"

 

Edit: Ignore me, I realised you can use the kexts instead

Share this post


Link to post
Share on other sites

Yes, also the rest of the instruction is in the same post above.

I guess I could've include full instruction in the text file as well.

  • Thanks 1

Share this post


Link to post
Share on other sites

I'd honestly go against anything related with patching your BIOS since any small mistake could render you high end latitude laptop useless.Jake Lo's bootpack contains the IntelGraphicsDVMTFixup kext, so in theory, you should be able to install macOS on your laptop without having to patch your BIOS like I did.

Share this post


Link to post
Share on other sites

Since WhateverGreen aims to be an ultimate graphic solution which replace all other graphic fixes, those other solutions are now deprecated and integrated in WhateverGreen. That includes IntelGraphicsDVMTFixup too, but do not expect that your DVMT problem would be fixed just by adding WhateverGreen to your Clover kexts folder as it was a case with IntelGraphicsDVMTFixup.

 

DVMT patch doesn't work "as is" and currently there is no simple switch that you can use. To fix DVMT, you need to set few framebuffer properties in Devices/Properties of your Clover config. Detail info here. Please check details in Preliminary part, since there is a list of things that should be removed if you are using WhateverGreen.

 

In short, you need to remove all other kexts and graphics injections and fixes in Clover related to graphics and to set framebuffer patches in Devices/Properties like this:

 

framebuffer-patch-enable01000000 (this is actually 00000001, but it needs to be in reverse order) - enable patch

framebuffer-stolenmem00003001 (this is actually 01300000) - set framebuffer to 19MB

framebuffer-fbmem00009000 (this is actually 00900000) - set cursor to 9MB


1638602284_ScreenShot2018-09-21at5_20_14PM.thumb.png.df5b22a1ddd54175caa26b1f9c6df6a0.png

 

EDIT:

 

Device path of your IGPU -  PciRoot(0x0)/Pci(0x2,0x0) should be added to Devices before setting properties.

Share this post


Link to post
Share on other sites

The IO addresses for laptops' GPUs are actually standard across the board; it's not just a Dell thing, it's the same for all computers, including Apple's own MacBooks

iGPU -> @0x00020000
dGPU -> @0x00010000

 

Share this post


Link to post
Share on other sites

Thank you very much @Hervé. That is very useful info. I just followed official instructions since I didn't knew that. I just noticed that in most Dell laptops that path is same. Now is clear why. I updated my previous comment to simplify it. 

Share this post


Link to post
Share on other sites
On 9/22/2018 at 1:37 AM, viking1304 said:

Since WhateverGreen aims to be an ultimate graphic solution which replace all other graphic fixes, those other solutions are now deprecated and integrated in WhateverGreen. That includes IntelGraphicsDVMTFixup too, but do not expect that your DVMT problem would be fixed just by adding WhateverGreen to your Clover kexts folder as it was a case with IntelGraphicsDVMTFixup.

 

DVMT patch doesn't work "as is" and currently there is no simple switch that you can use. To fix DVMT, you need to set few framebuffer properties in Devices/Properties of your Clover config. Detail info here. Please check details in Preliminary part, since there is a list of things that should be removed if you are using WhateverGreen.

 

In short, you need to remove all other kexts and graphics injections and fixes in Clover related to graphics and to set framebuffer patches in Devices/Properties like this:

 

framebuffer-patch-enable01000000 (this is actually 00000001, but it needs to be in reverse order) - enable patch

framebuffer-stolenmem00003001 (this is actually 01300000) - set framebuffer to 19MB

framebuffer-fbmem00009000 (this is actually 00900000) - set cursor to 9MB


1638602284_ScreenShot2018-09-21at5_20_14PM.thumb.png.df5b22a1ddd54175caa26b1f9c6df6a0.png

 

EDIT:

 

Device path of your IGPU -  PciRoot(0x0)/Pci(0x2,0x0) should be added to Devices before setting properties.

hi Viking1304

 

whate about for HD520.

framebuffer patches:

AAPL,ig-platform-id - 00001619

framebuffer-patch-enable01000000 (this is actually 00000001, but it needs to be in reverse order) - enable patch

framebuffer-stolenmem00003001 (this is actually 01300000) - set framebuffer to 19MB

framebuffer-fbmem00009000 (this is actually 00900000) - set cursor to 9MB

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...