Jump to content

Can't fix second stage glitch, nothing helps


viking1304
 Share

Recommended Posts

@Bronxteck I thought that that flag is only related to HDMI 2.0. I have only Full HD screen, so I guess it is not applicable here, but I will try that too.

 

I even tried this "solution" on many different Clover versions (in combination with kext patch and without it), but without success.

	<key>Graphics</key>
	<dict>
		<key>EDID</key>
		<dict>
			<key>HorizontalSyncPulseWidth</key>
			<string>0x64</string>
			<key>Inject</key>
			<true/>
		</dict>

More info here.

 

EDIT: I just tried to boot with -cdfon. No change at all.

 

At this point it is not important for me to fix this issue, but I really would like to understand why this happens.

 

I recored two videos, paused and manually switched frames to see what is happening. One video was made with external monitors attached, second one just with main display. I noticed this:

 

1. Boots starts normally

2. Laptop monitor goes off

3. Laptop monitor goes on

4. Then there is a flicker with a glitch (only on laptop monitor)

5. Laptop monitor goes off again

6. All 3 monitors turn on

7. Cursor is shown on all 3 monitors (clone mode)

8. Logo is shown again (this time on all 3 monitors)

9. Boot screen appears

 

Glitch appears before external monitors are turned on (I can notice difference between On and StandBy state on them), so it should not be related to DisplayLink drivers, but I am willing to remove them just to try and see will it make any difference.

 

@Jake Lo if I understood you correctly, you also noticed this glitch on E7450? If you noticed the same, then removing DisplayLink drivers would make no difference.

 

 

Link to comment
Share on other sites

With legacy bios off, laptop screen is completely garbled. I tried that too.

 

I actually managed to get "perfect boot" last night, but price was way too high. I booted in VESA only mode, without acceleration (-igfxvesa). Boot took at least three times longer than usual and I ended with 7MB of VRAM instead of 2GB as I have now, which makes laptop almost unusable. :)

 

Link to comment
Share on other sites

I would try to load newest vbios through Clover, or replace one in your device Firmware. There is a info about loading vbios through Clover in here: https://clover-wiki.zetam.org/configuration/graphics#graphics_loadvbios and for updating vbios in Firmware try this guide: https://www.win-raid.com/t154f16-Tool-Guide-News-quot-UEFI-BIOS-Updater-quot-UBU.html

Link to comment
Share on other sites

 Share

×
×
  • Create New...