Jump to content
lersy

Dell 7577 - Mojave Post Installation - USB Problem

Recommended Posts

Hey,

 

I have installed macOS Mojave to my Dell 7577. It seems lots of things working except USB ports. My computer has 3 USB port , all of them are capable of usb3 and usb2 functionality at the same time. They don't work. When I plug an USB2 or usb3 device nothing happens. Also my internal webcam doesn't work. God knows what else not working but I am sure usb is not working. Touchpad is a little bit glitchy but It is ok. Mojave not lightning fast but it is ok. This is a mackintosh and we can't expect everything works flawlessly. but usb ones are important.

 

I attached my efi folder here, can you look it up for me? 

 

Thanks , best wishes.

EFIcompressed.zip

Share this post


Link to post
Share on other sites

Thanks for answering,

 

USBInjectall.kext is installed in CLOVER/Kexts/Other also I tried this usb regarding patch it is in my config.list . Yet it doesn't include XHCI series kext. How can I decide which motherboard or kext ? XHCI series 100 , 200 or 300. I don't have it. Anyway if I switch my smbios to macbook air 6,2 , my usb starts functioning in usb2 but no usb3 device like external hard drives.

 

I tried other ones , but currently my smbios is set to macbook pro 14,3 which is closest to my processor.

 

 

Share this post


Link to post
Share on other sites

Can I ask, how did you install Mojave without working USB ports? I have the same computer and can't for the life of me get the installer to boot. High Sierra was no problem, but Mojave is not happening. I even just now tried your EFI folder and same thing, circle with line through it, or in verbose mode all the txt get distorted.

Share this post


Link to post
Share on other sites

Hey buddy,

 

I am running Mojave 14.3 with nearly all essential hardware parts working.

 

I am away from my pc for a couple of days so I can’t help you now. When I turn back to home, I can provide you files which you need

 

Be patient I will write a full guide for it 

Share this post


Link to post
Share on other sites

Or if anyone is willing to share their EFI folder from their installer- its so strange that installing High Sierra was so easy and yet the Mojave installer won't even boot. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...