Jump to content

Atheros AR5B93 very slow in Dell E7440


pathliving
 Share

Recommended Posts

Can anyone share kext with good speed on this wi-fi module AR5B93, because I changed channel width to 40MHz, set Auto channel, 11bgn Mode, enable WMM, tested Transmit Power (low, middle, high) in my wi-fi router TP-Link TL-WR841ND, but nothing to help

 

p.s. I am using AirPortAtheros40.kext and my laptop has 20-30mbps speed with this wi-fi module (for comparison my phone Nexus 6P has 50-60mbps speed. and on Windows 10 with AR5B93 laptop has ~50mbps speed)

Link to comment
Share on other sites

  • Administrators

AR5B93 is supported OOB, i.e. with the vanilla Atheros kext installed by default in OS X. Your speed issue is not kext related per sé but connection related (channel settings, negotiation of connection between card and router). If your router supports 2.4GHz and 5GHz networks, try and split the SSIDs; Sharing the same SSID on both types of network can interfere.

Link to comment
Share on other sites

But on macOS Mojave AR5B93 doesn't support OOB. When I put vanilla Atheros kext from High Sierra my laptop has slow wireless speed.

I live in house and I have 2 wi-fi routers with 2.4GHz, but when I turned off one of them(for testing minus one SSID) nothing changed :(

 

Link to comment
Share on other sites

  • Administrators

You could have specified that subtlety from the onset... Atheros cards are no longer officially supported in Mojave so feel free to test Atheros40 kext from other versions if you're game. You can always extract the kext with Pacifist app from past Combo Update packages available for download off Apple's web site.

 

Failing that, opt for a better card like DW1510; AR5B93 is getting a little long in the tooth today...

 

I took out my old little Latitude D430 out of its cupboard and replaced the DW1510 fitted into it by the AR5B93 card I have lying around. It's this exact Foxconn T77H047 card. 'booted ML and ran Ookla legacy tests. Results are as good as I expected at around 70-80Mbps:

 

channels.png

 

Throughput.png

 

Try and adjust your local connection settings. Good luck.

  • Like 1
Link to comment
Share on other sites

  • Administrators

Ok, took the DW1520 out of my D630 that runs Mojave 10.14.1 and replaced it by the AR5B93 card + installed 10.13.6's Atheros40 kext posted here.

 

The results are more or less identical to what I obtained with the D430:

AR5B93_Mojave.png

 

Whilst your network are listed as 802.11n, I can see that the card only achieves a connection at a transmit rate of 11Mbps when my card achieves 117 to 130Mbps. This is clearly where your issue is. AR5B93 is 2.4GHz only and my router only offers 20MHz channels, not 40MHz. Maybe you should stick to 20MHz...

Wifi_connection.png

 

Could also be linked to eventual limitation with Country Code...

 

Link to comment
Share on other sites

  • Administrators

You have multiple routers and presumably multiple wireless clients. 40MHz increases channel overlapping and likelihood of interference and packet loss, so clearly, 20MHz channels is the optimum choice. You'll find lots of info on this on the Web.

 

If you want to improve your current performance using 40MHz bandwidth, you should modify your routers channels settings and set them apart to avoid overlapping.

Link to comment
Share on other sites

 Share

×
×
  • Create New...