Jump to content
Dreer

Dell INSPIRION 14R 5420

Recommended Posts

Hi, i have the Dell Inspiron 14R 5420 (I not know what is the serie, but I think is 4000), do install Hackintosh on High Sierra 10.13.4 and install kexts essentials.

 

Now I need config the battery, brigthness. I try using ACPI Battery but don't work.

 

 

 

EFI

https://drive.google.com/open?id=1514VRpArC-n2rYSkO6yRmLN_3REKW15N

 

backup AML.zip

Captura de Tela 2018-11-23 às 14.28.27.png

Captura de Tela 2018-11-23 às 14.28.40.png

Extra.zip

Edited by Dreer
Added EFI folder

Share this post


Link to post
Share on other sites

@Jake Lo

I think this works! Would like create new post for others items or i can use this ?

* Don't hibernate;

* While restart give errors;

* Disabled Nvidia (930m)

* Bluetooth;

Share this post


Link to post
Share on other sites

 

@Jake Lo I tried to use gen_debug according to the guidelines but it arrives at a point that it gives error, saying that I have to renitiar the mac and press FN + F2 or just F2 on the CLOVER screen. I did this, generated some files in the ACPI folder but it keeps talking to renitiar and pressi the command. So I am sending a report generated by RunMe. If anything is missing, please let me know.

Send me Air-de-Douglas.zip

Share this post


Link to post
Share on other sites

Should be F2 and F4 @ Clover before to run the debug file 

Give this a try, replace Config file, add SSDT to /EFI/Clover/ACPI/Patched

See if it'll disable Nvidia and fix sleep as well

Make sure to disable hibernation as it's a prerequisite to get sleep & wake to work properly on a Hackintosh:

sudo pmset hibernatemode 0

sudo rm -f /var/vm/sleepimage

sudo pmset hibernatefile /dev/null

Share this post


Link to post
Share on other sites

@Jake Lo 

Okay, I run commands on the terminal and create a new log file in the attachment, but again freeze while restarting the mac. I updated the system to the new version: High Sierra 10.13.6

Spoiler

Anonymous UUID:       A09CCA78-C439-38CF-29B3-1E44FE60CF95

Wed Nov 28 20:50:30 2018

*** Panic Report ***
panic(cpu 2 caller 0xffffff80220bb179): "Element 0xffffff803736c8e0 from zone kalloc.32 caught being freed to wrong zone kalloc.16\n"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/xnu/xnu-4570.51.1/osfmk/kern/zalloc.c:3528
Backtrace (CPU 2), Frame : Return Address
0xffffff9148ecb3e0 : 0xffffff802206e166 
0xffffff9148ecb430 : 0xffffff8022196714 
0xffffff9148ecb470 : 0xffffff8022188a00 
0xffffff9148ecb4f0 : 0xffffff8022020180 
0xffffff9148ecb510 : 0xffffff802206dbdc 
0xffffff9148ecb640 : 0xffffff802206d99c 
0xffffff9148ecb6a0 : 0xffffff80220bb179 
0xffffff9148ecb780 : 0xffffff8022079e9a 
0xffffff9148ecb7d0 : 0xffffff802265ec76 
0xffffff9148ecb7f0 : 0xffffff7fa2d66c0b 
0xffffff9148ecb810 : 0xffffff7fa2d66cb0 
0xffffff9148ecb840 : 0xffffff7fa2d66da7 
0xffffff9148ecb860 : 0xffffff7fa2d67a8d 
0xffffff9148ecb890 : 0xffffff7fa2d67bbf 
0xffffff9148ecb8b0 : 0xffffff7fa2d35cc4 
0xffffff9148ecb8e0 : 0xffffff7fa2d374ce 
0xffffff9148ecb910 : 0xffffff802269b5e8 
0xffffff9148ecb980 : 0xffffff7fa2d37538 
0xffffff9148ecb9e0 : 0xffffff7fa2d375e5 
0xffffff9148ecba00 : 0xffffff7fa2d30d3d 
0xffffff9148ecba40 : 0xffffff7fa2d374ce 
0xffffff9148ecba70 : 0xffffff802269b5e8 
0xffffff9148ecbae0 : 0xffffff7fa2d37538 
0xffffff9148ecbb40 : 0xffffff7fa2d30a6e 
0xffffff9148ecbb70 : 0xffffff80222fff67 
0xffffff9148ecbbd0 : 0xffffff80222ffc4e 
0xffffff9148ecbca0 : 0xffffff80223092d0 
0xffffff9148ecbcd0 : 0xffffff802233f2d3 
0xffffff9148ecbcf0 : 0xffffff80222fc9d3 
0xffffff9148ecbd30 : 0xffffff802252a0ad 
0xffffff9148ecbdf0 : 0xffffff8022540fcf 
0xffffff9148ecbf40 : 0xffffff8022604418 
0xffffff9148ecbfa0 : 0xffffff8022020966 
      Kernel Extensions in backtrace:
         com.apple.iokit.IONetworkingFamily(3.4)[5A99D802-B477-3D83-9F76-304605479B9F]@0xffffff7fa2d2d000->0xffffff7fa2d5cfff
         com.insanelymac.ALXEthernet(1.0.2)[6348F8DB-1233-3D33-A7FD-66E3ED3E7EB6]@0xffffff7fa2d64000->0xffffff7fa2d71fff
            dependency: com.apple.iokit.IONetworkingFamily(3.4)[5A99D802-B477-3D83-9F76-304605479B9F]@0xffffff7fa2d2d000
            dependency: com.apple.iokit.IOPCIFamily(2.9)[1850E7DA-E707-3027-A3AA-637C80B57219]@0xffffff7fa2894000

BSD process name corresponding to current thread: launchd
Boot args: nv_disable=1 rootless=0 kext-dev-mode=1 -disablegfxfirmware -ath9485 

Mac OS version:
17E199

Kernel version:
Darwin Kernel Version 17.5.0: Mon Mar  5 22:24:32 PST 2018; root:xnu-4570.51.1~1/RELEASE_X86_64
Kernel UUID: 1B55340B-0B14-3026-8A47-1E139DB63DA3
Kernel slide:     0x0000000021e00000
Kernel text base: 0xffffff8022000000
__HIB  text base: 0xffffff8021f00000
System model name: MacBookPro10,2 (Mac-AFD8A9D944EA4843)

System uptime in nanoseconds: 27381238768763
last loaded kext at 21770269494743: com.apple.filesystems.msdosfs    1.10 (addr 0xffffff7fa4dc4000, size 69632)
last unloaded kext at 962508737707: com.apple.driver.AppleXsanScheme    3 (addr 0xffffff7fa45c0000, size 40960)
loaded kexts:
org.voodoo.driver.VoodooHDA    2.9.1
org.rehabman.voodoo.driver.PS2Mouse    1.9.2
org.rehabman.voodoo.driver.PS2Keyboard    1.9.2
com.insanelymac.ALXEthernet    1.0.2
org.rehabman.driver.AppleSmartBatteryManager    1.90.1
org.rehabman.voodoo.driver.PS2Controller    1.9.2
org.netkas.driver.FakeSMC    1765
com.sherlocks.IntelGraphicsDVMTFixup    1.2.0
as.lvs1974.IntelGraphicsFixup    1.2.6
as.lvs1974.NvidiaGraphicsFixup    1.2.4
com.rehabman.driver.USBInjectAll    0.6.4
as.vit9696.WhateverGreen    1.1.6
as.lvs1974.HibernationFixup    1.2.3
as.vit9696.AppleALC    1.3.3
com.hieplpvip.AppleBacklightFixup    1.0.2
as.vit9696.Lilu    1.2.8
org.tgwbd.driver.NullCPUPowerManagement    1.0.0d2
com.apple.filesystems.msdosfs    1.10
com.apple.filesystems.autofs    3.0
com.apple.driver.AppleUpstreamUserClient    3.6.5
com.apple.driver.AppleMCCSControl    1.5.4
com.apple.driver.AppleMikeyHIDDriver    131
com.apple.AGDCPluginDisplayMetrics    3.18.48
com.apple.driver.AGPM    110.23.33
com.apple.driver.ApplePlatformEnabler    2.7.0d0
com.apple.driver.X86PlatformShim    1.0.0
com.apple.driver.AppleHV    1
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.iokit.IOBluetoothSerialManager    6.0.5f3
com.apple.driver.pmtelemetry    1
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleIntelHD4000Graphics    10.3.2
com.apple.driver.AppleMikeyDriver    281.51
com.apple.driver.AppleSMCPDRC    1.0.0
com.apple.driver.AppleOSXWatchdog    1
com.apple.driver.AppleLPC    3.1
com.apple.driver.AppleSMCLMU    211
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.driver.AppleIntelFramebufferCapri    10.3.2
com.apple.filesystems.hfs.kext    407.50.6
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.BootCache    40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.iokit.SCSITaskUserClient    404.30.2
com.apple.filesystems.apfs    748.51.0
com.apple.driver.AirPort.Atheros40    700.74.5
com.apple.driver.AppleAHCIPort    329.50.2
com.apple.driver.AppleACPIButtons    6.1
com.apple.driver.AppleBacklight    170.12.6
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleHPET    1.8
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    183
com.apple.security.TMSafetyNet    8
com.apple.security.quarantine    3
com.apple.driver.AppleIntelCPUPowerManagement    220.50.1
com.apple.kext.triggers    1.0
com.apple.iokit.IOAVBFamily    675.6
com.apple.plugin.IOgPTPPlugin    675.12
com.apple.iokit.IOEthernetAVBController    1.1.0
com.apple.driver.AppleSSE    1.0
com.apple.iokit.IOBluetoothFamily    6.0.5f3
com.apple.AppleGPUWrangler    3.18.48
com.apple.driver.AppleSMBusController    1.0.18d1
com.apple.driver.AppleHDAController    281.51
com.apple.iokit.IOHDAFamily    281.51
com.apple.iokit.IOAudioFamily    206.5
com.apple.vecLib.kext    1.2.0
com.apple.iokit.IOSerialFamily    11
com.apple.driver.AppleSMBusPCI    1.0.14d1
com.apple.driver.X86PlatformPlugin    1.0.0
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.iokit.IOAcceleratorFamily2    378.18.1
com.apple.iokit.IOSurface    211.12
com.apple.AppleGraphicsDeviceControl    3.18.48
com.apple.driver.usb.IOUSBHostHIDDevice    1.2
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.usb.AppleUSBHub    1.2
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IOUSBFamily    900.4.1
com.apple.iokit.IOSCSIMultimediaCommandsDevice    404.30.2
com.apple.iokit.IOBDStorageFamily    1.8
com.apple.iokit.IODVDStorageFamily    1.8
com.apple.iokit.IOCDStorageFamily    1.8
com.apple.iokit.IOAHCISerialATAPI    267.50.1
com.apple.iokit.IOAHCIBlockStorage    301.40.2
com.apple.iokit.IO80211Family    1200.12.2
com.apple.driver.corecapture    1.0.4
com.apple.iokit.IOAHCIFamily    288
com.apple.driver.usb.AppleUSBEHCIPCI    1.2
com.apple.driver.usb.AppleUSBEHCI    1.2
com.apple.driver.usb.AppleUSBXHCIPCI    1.2
com.apple.driver.usb.AppleUSBXHCI    1.2
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.driver.AppleBacklightExpert    1.1.0
com.apple.iokit.IONDRVSupport    519.15
com.apple.iokit.IOGraphicsFamily    519.15
com.apple.iokit.IOSMBusFamily    1.1
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.driver.DiskImages    480.50.10
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleEffaceableStorage    1.0
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleUSBTDM    439.50.6
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.iokit.IOUSBMassStorageDriver    140.50.3
com.apple.iokit.IOSCSIBlockCommandsDevice    404.30.2
com.apple.iokit.IOSCSIArchitectureModelFamily    404.30.2
com.apple.iokit.IOStorageFamily    2.1
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.2
com.apple.driver.usb.AppleUSBCommon    1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor    1
com.apple.iokit.IOReportFamily    31
com.apple.iokit.IOTimeSyncFamily    675.12
com.apple.iokit.IONetworkingFamily    3.4
com.apple.driver.AppleACPIPlatform    6.1
com.apple.driver.AppleSMC    3.1.9
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread    1
com.apple.kec.corecrypto    1.0
com.apple.kec.Libm    1

EOF
Model: MacBookPro10,2, BootROM 274.0.0.0.0, 2 processors, Intel Core i5, 2,49 GHz, 8 GB, SMC 2.6f59
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0000, -
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, Kingston, 9905469-143.A00LF
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x209), Atheros 9485: 4.0.74.0-P2P
Bluetooth: Version 6.0.7f10, 3 services, 26 devices, 1 incoming serial ports
Network Service: Rede Sem Fio, AirPort, en1
PCI Card: Intel Corporation, Series Chipset USB xHCI Host Controller, USB Controller, Built In
PCI Card: Intel Corporation, Series Chipset MEI Controller, IMEI Controller, Built In
PCI Card: Intel Corporation, Series Chipset USB Enhanced Host Controller #2, USB Controller, Built In
PCI Card: Intel Corporation, Series Chipset USB Enhanced Host Controller #1, USB Controller, Built In
PCI Card: Intel HD Graphics 4000, VGA-Compatible Controller, PCI Slot 3
PCI Card: Intel Corporation, Series Chipset SATA Controller, AHCI Controller, Built In
PCI Card: Atheros 9485 Wireless Network Adapter, AirPort Extreme, Built In
PCI Card: ALX Ethernet Driver, Ethernet Controller, Ethernet
Serial ATA Device: KINGSTON SA400S37120G, 120,03 GB
Serial ATA Device: TSSTcorp DVD+/-RW SN-208BB
USB Device: USB 3.0 Bus
USB Device: G300s Optical Gaming Mouse
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Bluetooth USB Host Controller
USB Device: USB 2.0 Bus
USB Device: Hub
USB Device: Laptop_Integrated_Webcam_HD
USB Device: USB2.0-CRW
Thunderbolt Bus: 

debug_3720.zip

Share this post


Link to post
Share on other sites

Files that I attached were to be replacing your files, not merge.

Here, try again. Replace the contents into /EFI/Clover

You can make a back 1st to be safe.

 

Remove the following from /S/L/E, repair permissions and rebuild cache. They are meant to be in Clover folder which I had included

Lilu.kext

AppleBacklightFixup.kext

HibernationFixup.kext

 

 

Archive.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...