Jump to content

E6230 Mojave sleep, webcam, sound, cpu


Recommended Posts

Hi there,


For quite some time, im having some issues. The main thing about these problems is that they aren't always here.


1. Cpu bus speed, instead of 100 mhz, it's at 99 mhz, which is weird cuz im getting clock rates for example 1.19ghz, 2.18ghz and the final is 3,37. From my knowledge under windows it at least showed me right ones: 1.2, 2,2 etc. i guess it isn't really the problem, since it is always like that and is not working "sometimes". Never seen here 3.6 ghz turbo boost speed..


2. These other problems are somehow related to sleep or something like that. The weird thing is that they stop working randomly, after browsing the web for some hours and then out of no where i got no sound. Next time a situation like that and there is sound but the webcam doesn't work. It usually begins to work after couple of restarts. 


Anything other than SMBIOS 10.1 and my webcam doesn't work at all.


Of course these problems appear when i need to make a quick facetime call, i open up the computer and seems like everything is falling apart :D. Apps won't open up correctly, meaning for example the chrome opens up, but nothing loads. When this occurs and i try to restart the computer, the screen goes black and that little loading thing stays there for i don't know long (i'm doing hard reset after 5 minutes).


E: Another thing, charging percentage is not updating sometimes. It updates only when i toggle the percentage on/off. Charging too, it stays the way as i power on the pc. If turn on without the cord, it doesn't show that it is charging until i restart. When i do, it shows charging and it does not matter wheter plug the cord or not. In short it stays the way i turn on the computer..


I've updated some of my kext's but nothing. Seems more like some patching problem, but don't understand exactly where and what.a




Link to comment
Share on other sites

  • Administrators

1) it's perfectly normal. A clock cannot be expected to run exactly at 100MHz so there will always be a tiny drift. This being said, if you want your reported speeds to be sport on, set up bus speed to 100MHz in your Clover config. I advise you use Clover Configurator to that effect è-> CPU section.


2) You ain't exactly clear, and I'm having trouble understanding what your issues are here... I've been running MBP9,2 SMBIOS from the onset, whether with my previous i5-3340M or my current i7-3540M and can't report any problem with that.


Will look into your posted debug info later but it defintiely seems your system is not entirely properly setup.


Link to comment
Share on other sites

To be exactly clear. it shows me that webcam is disconnected. Sometimes there is no sound. Speaker icon remains working and sliders and stuff are working but there is nothing coming out of the speakers. 


Charging percentage stuck. Changes only when i toggle On/Off. Battery status (charging/battery power) icon stays the way as it was when device booted up. 


Bus speed manually adjusted, thanks for that, like to be spot-on :D

Idle processor speed seems a little high 1.2ghz. Under windows it was 800mhz. When i disconnect or connect the plug it goes down to 900 for about 1-2 seconds.

Link to comment
Share on other sites

  • Administrators

1.2GHz is the normal idle speed (=Low Frequency Mode) unless you have a CPU power management problem.


You may check your own CPU's LFM/HFM speeds in Intel's Ivy Bridage datasheet, p34-35.



Only the low-voltage "U" models have LFM @800MHz.


Link to comment
Share on other sites

  • Administrators

There are several things to adjust in terms of both kexts and Clover config.



  • You wish to inject FakePCIID_XHCMux kext but you forgot to include the FakePCIID kext that's required as main base. That may explain your USB issues. I recommend you familiarise yourself with Rehabman's FakePCIID documentation.


Clover config:

  • ACPI section
    • You have a generated power management SSDT for your CPU, yet tried configured Clover with PluginType (and incorrectly so. Remove those Clover parameters (PluginType, APSN, APLF).
    • You have disabled the renaming of USB devices EHCx to EH0x. You might as well remove them since, indeed, they're not needed on this laptop, at least with MPB9,2 SMBIOS
  • Boot section
    • You don't need to set kext-dev-mode=1, nv_disable=1 or slide=0. Remove those settings.
    • Latest versions of Lilu and AppleALC kexts support Mojave so you can also remove those -lilubeta and -alcbeta options as long as you inject latest versions of the kexts through your Clover kexts folder.
  • Devices section
    • You may want to enable High Current for your USB ports (there are USB3.0 ports on the E6230 and one of them is PowerShare capable)
  • Disable Drivers section
    • You can remove the disabling of VBoxHfs
  • Graphics section
    • All Ok there. Remove Inject Intel + Capri layout 0x01660003 if you ever inject WhateverGreen kext
  • Kernel and kext patches section
    • KernelPm is not applicable to Ivy Bridge. It's for Haswell and later platforms. Remove that.
    • Your IOGraphicsFamily patch is incorrect. It's the patch that applied to older OS X versions. Since High Sierra (or was it Sierra?) the patch differs to replacing 0100007522 by 010000EB22
    • In the same spirit the USB port list patch of your config no longer applies to Mojave. You can remove it.
    • I would change SMBIOS to MacBookPro9,2
    • Once that is done generate a new Serial Number + SmUUID number
  • System Parameters
    • Once you've changed SMBIOS, generate a new Custom UUID
  • Rt Variables
    • You may then generate a new ROM from SMBIOS and copy the listed MLB value to the MLB field.


Try this one:


Link to comment
Share on other sites

Wow, thanks. Added that FakePCIID and applied that config, generated new sn and everything seems to be working. I think these mistakes came from my previous high sierra.. And i guess i watched different kind of topics and tried to fix those. After all should have asked here first :)


Only thing is that battery icon, seems like the percentage is now updating in both ways, but the icon does not show if it is plugged in or not.

Link to comment
Share on other sites


  • Create New...