Jump to content

long time to boot time out.. ADP1 BAT0 (E7440_mojave)


girardpallet
 Share

Recommended Posts

hi,

after trying to fix my battery indicator, i'v made so many change (didn't even remember...)and finally now my computer start but the booting time is more than 4 minutes !

and i have also a KP at shutdown..

what else you need to help me..?

attached 2 pics: 0029 is suspend at boot and img_0032 is the KP at shutdown. and also debug zip file

thank

 

IMG_0029.JPG

IMG_0032.JPG

debug_20620.zip

Link to comment
Share on other sites

  • Administrators

You use Lilu +WEG, so:

  1. update those 2 x kexts to the latest versions
  2. remove FakePCIID_Intel_HD_Graphics + IntelFixUp kexts; they're not required since you use Lilu + WEG

 

Using Clover Configurator app, in your Clover config:

  1. Graphics section: remove "Inject Intel" + layout -id 0x0a260006. Lilu + WEG take care of that and it's already injected in the patched DSDT
  2. ACPI section: remove ssdt.aml from SortedOrder box
  3. ACPI section: remove SSDT entries CpuPm + Cpu0Ist from Dropped Tables box
  4. ACPI section: untick Drop OEM from SSDT options
  5. Devices section: no need to fake 0x04128086, it's already injected in the patched DSDT
  6. Kernel & Kext Patches section: enable KernelXCPM option

 

Spoiler
        Device (IGPU)
        {
            Name (_ADR, 0x00020000)  // _ADR: Address

           [...]

            Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
            {
                If (LEqual (Arg2, Zero))
                {
                    Return (Buffer (One)
                    {
                         0x03                                           
                    })
                }
                Return (Package (0x08)
                {
                    "device-id", 
                    Buffer (0x04)
                    {
                         0x12, 0x04, 0x00, 0x00                         
                    }, 
                    "AAPL,ig-platform-id", 
                    Buffer (0x04)
                    {
                         0x06, 0x00, 0x26, 0x0A                         
                    }, 
                    "hda-gfx", 
                    Buffer (0x0A)
                    {
                        "onboard-1"
                    }, 
                    "AAPL00,DualLink", 
                    Buffer (0x04)
                    {
                         0x01, 0x00, 0x00, 0x00                         
                    }
                })
            }
        }

NB: DualLink not required on Haswell iGPU afaik

 

 

While looking at your DSDT, I also noticed a duplicate entry in the HPET device. I can't say if that's likely to cause an issue but I'd recommend you remove this duplicate:

                Device (HPET)
                {
                    Name (_HID, EisaId ("PNP0103"))  // _HID: Hardware ID
                    Name (_UID, Zero)  // _UID: Unique ID
                    Name (BUF0, ResourceTemplate ()
                    {
                        IRQNoFlags ()
                            {0,8,11,15}
                        IRQNoFlags ()                                      --> Duplicate code
                            {0,8,11,15}                                    --> Duplicate code
                        Memory32Fixed (ReadWrite,
                            0xFED00000,         // Address Base
                            0x00000400,         // Address Length
                            )
                    })
                    Name (_STA, 0x0F)  // _STA: Status
                    Method (_CRS, 0, NotSerialized)  // _CRS: Current Resource Settings
                    {
                        Return (BUF0)
                    }
                }

-

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...