Jump to content
Alzaka

Dell 5558 Mojave , no touchscreen

Recommended Posts

I have the following Dell Laptop running Mojave. 

 

Dell inspiron 5558 Haswell i3-4030u

-HD4400 works

-Ethernet Works

-Touchscreen Does not work

-Sound Works

-Wifi intel - Will never work

-Usb - Works

Battery works

-Webcam Does not work

 

I noticed most people with this laptop have the touchscreen working once they install OSX but it does not work for me. Anyone know what I am missing?

 

thanks

 

Alz

Share this post


Link to post
Share on other sites

Jake,

 

It was definitely a usb issue. Thanks for pointing it out. Now working on the audio. I was using voodooHDA but the audio would sometimes disappear when i rebooted. Working on getting AppleALC to work

 

thanks for the help

 

Alz

Share this post


Link to post
Share on other sites

Jake,

 

that works amazing, even autodetects the headphones when i plug in and switches back to internal speakers when I unplug the headphones.

Microphone works from the laptop and from the headset

 

thanks again

 

Alz

Share this post


Link to post
Share on other sites

Did you create an USBPort.kext and did it enabled all your USB devices?

Does touchscreen and webcam work now?

Can you attach the kext for review?

Share this post


Link to post
Share on other sites

Jake,

 

I took the short route, but i really should build the USBport.kext

 

EFI/Clover/Kexts/Other >> USBInjectAll.kext

 

Library/Extensions >> GenericUSBXHCI.kext, FakePCIID_XHCIMux.kext, XHCI-unsupported.kext

 

I rebuilt the kext cache with sudo kextcache -i / and after reboot the following devices appeared in system information, Hardware > usb

 

Touchscreen, Bluetooth-HCI, Integrated_Webcam_HD, USB2.0-CRW (All internal to the laptop)

 

I attached a picture. Haven't tested USB3.0 yet

 

Still need to order some Dell Wifi cards that will be compatible with Mojave. Using a USB one for now but it is only 802.11n speeds

 

thanks

 

Alz

Screen Shot 2019-01-17 at 6.21.40 PM.png

Share this post


Link to post
Share on other sites

I removed those 2 kexts and bootup is much faster and cleaner. During bootup, the apple logo would blank for a few seconds. Removing these kexts stopped the logo from blanking

 

thanks for you help again

 

Alz

Share this post


Link to post
Share on other sites

Please. Help me!!!

Help me! How to install Mojave on a 5558 i3 5002u hd5500 laptop?
Need a working clover folder !!!
chebaa81@mail.ru

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...