Jump to content
Alzaka

Dell 7559 , OSX Mojave Install

Recommended Posts

Tried Installing Mojave on the a Dell 7559

Dell 7559 i7-6700hq, 16GB Ram, 500GB Sata SSD, Intel 530 (GTX960M not in use) , 1080p No Touch display, DW1560 Wireless , Bios 1.20

 

What works

USB(Complains it has 11 missing ports)

Bluetooth

Trackpad

Keyboard

Wifi (Original Card was replaced with Dell DW1560)

Graphics (I think)

Sound started working (not sure how)

 

Not working

Battery Status, Backlight, Keyboard Backlight, Sleep/Power Management, HDMI Audio

 

I used the following config.plist (Attached)

 

This is what is in EFI/Clover/Kexts/Other

 

ACPIBatteryManager.kext            FakePCIID_Broadcom_WiFi.kext        Lilu.kext
AirportBrcmFixup.kext            FakeSMC.kext                RealtekRTL8111.kext
AppleALC.kext                FakeSMC_ACPISensors.kext        SATA-100-series-unsupported.kext
AppleBacklightInjector.kext        FakeSMC_CPUSensors.kext            Sinetek-rtsx.kext
ApplePS2SmartTouchPad.kext        FakeSMC_GPUSensors.kext            USBInjectAll.kext
BrcmFirmwareData.kext            FakeSMC_LPCSensors.kext            VoodooTSCSync.kext
FakePCIID.kext                IntelGraphicsFixup.kext            WhateverGreen.kext

 

This is what is in /Library/Extensions

BrcmFirmwareRepo.kext BrcmPatchRAM2.kext CodecCommander.kext

 

 

NO DSDT/SSDT Patches, I think this is the cause of most of the problems, I am working on this next

 

 

Any suggestions ?

I had some trouble just getting the installer to work but having the right config.plist is the key with this particular laptop

 

 

 

thanks

Alz

config.zip

Share this post


Link to post
Share on other sites

Try this config

Move AppleBacklightInjector.kext to /L/E, won't work in clover kexts/other

repair permissions and rebuild cache

 

For sleep to work, you'll need to disable the Nvidia graphics

config-7559.plist.zip

Share this post


Link to post
Share on other sites

I did the DSDT patches and everything seems much cleaner, no more ACPI errors on bootup

I also patched the gtx 960 to be disabled

 

What works

USB

Bluetooth

Trackpad (As a mouse, no gestures)

Keyboard

Wifi (Original Card was replaced with Dell DW1560)

Graphics

Battery Status

Backlight

Sound

 

Not working

Sleep - still does not work after disabling the Discrete GPU, No HDMI Audio, Trackpad not detected, work as a mouse

 

I patched audio layout 3 and changed it to 13, added codeccommander.kext and ALC256.aml, but still no sound

Patched the DSDT, as 0x0D (which is 13 in hex) and the sound is working

 

thanks

 

Alz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×