Jump to content
elisir1998

XPS9360 + Mojave Bluetooth not working

Recommended Posts

Not showing in your IOREg file

Check if it's not showing up under USB in your system information, if not, then it's an USB issue. You don't have it configure correctly.

Also need the following 2 kexts in /L/E

BrcmPatchRAM2.kext

BrcmFirmwareRepo.kext

Share this post


Link to post
Share on other sites

This is what I have under USB in my system information:
 

BCM2045A0:

 

  ID prodotto: 0x6410

  ID fornitore: 0x0a5c  (Broadcom Corp.)

  Versione: 1.12

  Numero di serie: 40490FFE693E

  Velocità: Fino a 12 Mb/s

  Produttore: Broadcom Corp

  ID posizione: 0x14300000 / 2

  Corrente disponibile (mA): 500

  Corrente operativa extra (mA): 0

  Integrato: Sì

 

I tried to copy BrcmPatchRAM2.kext BrcmFirmwareRepo.kext in /L/E. after fixing permission and rebuilding cache and restart....it stucks on boot on

AppleIntellpassI2CController::_ServicematchingTimeSubr: ftimerServiceMatching timed out, fNotification 0

kextd stall[0], (60s): 'BCM2045A0'

kextd stall[1], (60s): 'BCM2045A0''

and so on....

Share this post


Link to post
Share on other sites

I tried to copy that 2 kext in my EFI on kext/other

 

the result is that bluetooth icon appears, but it is not working

and now under system information I have the bluetooth adapter shower up

Versione software Bluetooth di Apple: 6.0.10f1

  Hardware, funzionalità e impostazioni:

  Nome: MacBook Pro di Salvatore

  Indirizzo: 40-49-0F-FE-69-3E

  Bluetooth a basso consumo supportato: Sì

  Handoff supportato: Sì

  Instant Hotspot supportato: Sì

  Produttore: Broadcom

  Collegamento: USB

  Chipset: 20703A1

  Versione firmware: v5 c4096

  Stato Bluetooth: Attivo

  Visibile: Non attivo

  Accetta connessioni: No

  Ricerca automatica dispositivo di puntamento: Attivo

  Riattivazione remota: Attivo

  ID produttore: 0x0A5C

  ID prodotto: 0x6410

  Versione HCI: 4.1 (0x7)

  Revisione HCI: 0x1000

  Versione LMP: 4.1 (0x7)

  Sottoversione LMP: 0x2105

  Tipo di dispositivo (principale): Computer

  Tipo di dispositivo (completo): Mac Portable

  Classe composita del dispositivo: 0x38010C

  Classe dispositivo (principale): 0x01

  Classe dispositivo (secondaria): 0x03

  Classe servizio: 0x1C0

  Ricerca automatica tastiera: Attivo

  Servizi:

  Trasferimento file Bluetooth:

  Cartella accessibile ad altri dispositivi: ~/Public

  Quando si ricevono degli elementi: Accetta tutto senza avvisare

  Stato: Disabilitato

  Scambio file Bluetooth:

  Cartella per elementi accettati: ~/Downloads

  Quando vengono accettati altri elementi: Salva

  Quando si ricevono degli elementi: Accetta tutto senza avvisare

  Stato: Disabilitato

  Condivisione Internet Bluetooth:

  Stato: Disabilitato

  Porte seriali in entrata:

  Bluetooth-Incoming-Port:

  Canale RFCOMM: 3

  Richiede l'autenticazione: No

 

 

what can I try? Wifi is always ok

Share this post


Link to post
Share on other sites

If you place them in kext/Other, then you'll need to replace BrcmFirmwareRepo.kext with BrcmFirmwareData.kext.

Share this post


Link to post
Share on other sites

I tried right now:

BrcmFirmwareData.kext and BrcmPatchRam2.kext in kext/other...it stucks on boot always in the same point like before

 

no Luck

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...