Jump to content
PayPal donations: [email protected] ×

Install High Sierra on Latitude E6420

Recommended Posts

Here are my laptop specs.





I followed this guide

I can only get this far. I am not sure what version of High Sierra it is have downloaded on my VMware virtual machine. If I "get info" on the "install macOS High Sierra" in application folder. It shows 13.6.02, which I know is not the actual version, don't know how to download newer version.



Then I get this.



I have attached my EFI folder. This is setup for Legacy - GUID Scheme.

I will also look to see if I can find a place to download version 10.13.6


Thank you for your help in advance.





Share this post

Link to post
Share on other sites

I think that is version 10.13.6.

Make sure you have Optimus enabled in the BIOS, and AHCI enabled.

In Config file, change SMBIOS to MBP 8,2, the usb_injector kext is hard coded to MBP8,2.

In EFI/Clover/drivers64UEFI, add HFSPlus.efi. Link found in the guide.

Share this post

Link to post
Share on other sites

Thank you for your help.


What you posted worked. I was able to install 10.13.5, which what I had downloaded. I tried to update to 10.13.6 and that crashed. I found a copy of 10.13.6 online. I was able to install and get it updated with all updates.


I am still seeing ACPI error at boot up (see below). Can you point me into the right place that will help fixing these issues?


Thank you for your help in advance.





Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...