Jump to content
Sign in to follow this  

[Solved] NVME LATITUDE 7490

Recommended Posts

I cant partition the m2 disk to dualboot, Have tried to install either one of windows and mojave and create two partitions and once installed and up try to install the other OS. But when I install the second OS no matter if its Mojave or Windows 10 it will format the whole disk and not just the selected parition.

I am begenning to wonder if its a faulty hardware? 

Any help is greatly appretiated.

Share this post

Link to post
Share on other sites

'doubt it but maybe you're doing it wrong.


Say you install Windows on a single partition on the SSD, you can then reduce that partition from Windows and create a new partition in the freed space. You may then format that partition FAT or NTFS. You may then boot your Mojave installer USB key and, once at the main screen, open up Disk Utility to reformat that 2nd empty partition HFS+ or APFS. You should then be able to install Mojave on that freshly reformatted partition.


Make sure that, from the onset, you partition your disk using a GPT/GUID scheme, not MBR.


Share this post

Link to post
Share on other sites


I did exactly as you described above, but even if I choose the partition I made att on windows the OSX installer uses the whole disk.

I tried then to install Mojave first and partition the disk into two partitions, one for windows and the other for Mojave. Mojave installed ok but when i booted from windows Usb installer and choose the partition created for windows, the windows installer did format all the drive.

I have som experience of hackintosh on desktops but this is my firs laptop. I am no total noob but this is very very strange.


Share this post

Link to post
Share on other sites

Very weird. I installed Mojave on my M.2 SATA SSD after reducing the Win10 partition it came installed with. I had no issue whatsoever in installing Mojave on the recovered disk space once I booted my Mojave USB installer.


My SSD partitioning arrangement now looks like this (Win10 + Mojave + Catalina):

Last login: Sun Aug  4 03:03:52 on ttys000
lat-7490:~ admin$ diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *512.1 GB   disk0
   1:                        EFI BOOT                    523.2 MB   disk0s1
   2:         Microsoft Reserved                         134.2 MB   disk0s2
   3:       Microsoft Basic Data Windows                 399.0 GB   disk0s3
   4:                 Apple_APFS Container disk2         81.8 GB    disk0s4
   5:                 Apple_APFS Container disk1         30.7 GB    disk0s5

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +30.7 GB    disk1
                                 Physical Store disk0s5
   1:                APFS Volume Catalina - Data         5.8 GB     disk1s1
   2:                APFS Volume Preboot                 77.6 MB    disk1s2
   3:                APFS Volume Recovery                520.4 MB   disk1s3
   4:                APFS Volume VM                      1.1 GB     disk1s4
   5:                APFS Volume Catalina                10.1 GB    disk1s5

/dev/disk2 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +81.8 GB    disk2
                                 Physical Store disk0s4
   1:                APFS Volume Mojave                  47.0 GB    disk2s1
   2:                APFS Volume Preboot                 45.5 MB    disk2s2
   3:                APFS Volume Recovery                510.3 MB   disk2s3
   4:                APFS Volume VM                      20.5 KB    disk2s4

lat-7490:~ admin$






Share this post

Link to post
Share on other sites
This topic is now closed to further replies.
Sign in to follow this  

  • Create New...