Jump to content

Hackintosh for Dell Inspiron 15 3558


Recommended Posts


I'm having dell inspiron 15 3558 laptop, I've tried installing using latest clover but when I boot using the bootable pendrive clover doesn't start (shows only black screen).

I'm not getting what may be the problem is it due to config.plist or my bios fault. 

Also I've done all the changes in BIOS which is required.



Thank You!


Link to comment
Share on other sites

Hello Jake,

Thanks for your reply.


My laptop full Specification are:

  • Dell Inspiron 15 3558    
  • BIOS A18
  • Intel Core i5-5200U @ 2.20GHz
  • Intel HD Graphics 5500 + NVIDIA GeForce 920M
  • Network Adapter : Realtek


Initially when I used the latest clover and config.plist which is provided by RehabMan, the clover screen doesn't appear just BLACK SCREEN.

After that I've read your post and found a "Patched Clover folder (for dell A10 BIOS)", after replacing the clover folder the Clover screen do appear. 

After clicking on created macos drive for installation the PC Restarts. 

I'm trying to install Mojave 10.14.6.



Link to comment
Share on other sites

Hello Jake Lo,

I've tried the given file also by creating the boot option by pointing to /EFI/Clover/Cloverx64.efi, but still it stuck at Dell logo.

And if I tried using one time boot menu it stuck at black screen.


Link to comment
Share on other sites

  • Moderators

Those are not the files I have posted. 

Your DSDT.aml is from an Asus system. Your Config file is a mess. Your kexts are really outdated.

You're missing Clover files from 2017....

Can't imagine why it would boot with those files.


Reinstall Clover with the following settings with Clover version from here

  • Install for UEFI booting only
  • Install Clover in the ESP
  • UEFI Drivers\Recommended Drivers
    • ApfsDriverLoader
    • AptioMemoryFix
    • AudioDxe
    • DataHubDxe
    • FSInject
    • HFSPlus
  • Additional drivers
    • PartitionDxe
  • Themes (Optional)

Replace the attached files I attached above into /EFI/Clover

Try booting again and post the result

Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...