Jump to content

E7450 | Successfull update to macOS Catalina 10.15


Recommended Posts

Hi everyone,


as the subject of my topic, I just want to share my personal experience about updating my E7450 (with Intel HD graphics only) from Mojave 10.14.6 to Catalina 10.15.

First of all, I've just tried the updating for an external toshiba 256GB SSD used with a 3.0 USB case.

The steps I followed are:

1. Follow the guide published by @Jake Lo and remember to use DSDT new hotpatch:

2. download catalina from system update utility

3. update clover to the latest version + lilu + AppleALC + WEG + kexts in /L/E

4. install catalina from the app

5. Bluetooth issue: for those who replaced the DW1560, use the guide here https://www.insanelymac.com/forum/topic/339175-brcmpatchram2-for-1015-catalina-broadcom-bluetooth-firmware-upload/, download the kexts and use also the BrcmBluetoothInjector (it has been re-written to be used with the BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext).

6. Repair permission and rebuild cache

That's it!


I hope to have been helpful for some of you





Link to comment
Share on other sites

Hi @terorero,


in order not to waste my personal space in the forum, I link the efi folder to my personal dropbox. https://www.dropbox.com/sh/zkqviawydpao2px/AABIabLKc6ajW_QBn3ZiMCZha?dl=0

Kexts should be updated, but please check.

Remove the microsoft folder if you don't have a windows partition on your disk.

Let us know if you have problems about.





Link to comment
Share on other sites

If you have an external hard drive, please consider to test the EFI folder with that. I’m still running Mojave on the internal SSD in order to properly test my external system. 
If you are able to test your system with a secondary drive, clone your main partition to the secondary drive, install Catalina with the shared EFI, and test your own system. I’m not a “pro”.. so please keep in mind. 

let us know about your test





Link to comment
Share on other sites

Update: 28 Oct 2019


After updating to the latest clover (v5097) I encountered problems with broken bluetooth during sleep/wake in battery mode, which caused the complete freeze of the entire system!

So I replaced my kexts in /L/E with those of Meize as already reported by @Jake Lo: this made the system not freezing anymore, but bluetooth is still unavailable after waking up from sleep. In any case, I updated my EFI folder in my personal dropbox space.

I would like to build again my usbports.kext (since bluetooth is strictly related to usb ports) in order to see if I am able to solve or not. 

I will keep it updated

Link to comment
Share on other sites

Update 29 Oct 2019


Using the above mentioned method (with BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext, v.2.5.0) I'm still getting issues, because bluetooth firmware is not updated properly. The same issue occurs using v. 2.2.12 (latest published release on github) of BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext (BrcmPatchRAM3.kext was not released with 2.2.12) and v. 2.5.0 of BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext. 

So this is an issue I'm not able to solve.

In any case, it is quite a strange issue because the same DW1560 (same vendor and ID) is installed on the other hack I have (HP Probook 560 G5) and for that it is working with no issues using v. 2.2.12

I don't understand why


Edit: using BrcmBluetoothInjector.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM3.kext, v.2.3.0d3, firmware is correctly uploaded. 

I may conclude you will have to try different solutions in order to find your best fit for your machine.

I'm not a wizard at all!!


Edit #2: don't claim for a conclusion when it is not concluded at all! After 2 reboots, bluetooth firmware is not uploaded again anymore. I'm starting to be frustrated..it seems totally a mess..

Link to comment
Share on other sites


Do you have problems with changing languages with capslock in Catalina ? 


I have this bug on Mojave  10.14.6. I can't change between 2 language with internal keyboard (Capslock bug)  but If i use USB keyboard it work fine


- Dell lattitude E5450



Link to comment
Share on other sites

Hello, I am totally new to this hackintosh world... I'm a Linux developer, trying to build some react-native application in iOS, so I'm in need of a worinkg mac to get XCode installed to build it.

I have Latitude E7450 Intel Graphics.

I tried @acquarius.13 dropbox's EFI. It installed very quick, but I have no wifi.

Any help or guidance, tutorial link, etc would be very appreciated

If there is any other info that would be useful to help me please let me know...

Thank you!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...