Jump to content

My D630 Install (and questions, of course!)


Dave C
 Share

Recommended Posts

Hi All

 

First off let me thank everyone who has contributed to this site, the EDP, the Extra folder, instructions, forums etc etc, made doing this installation pretty painless and enjoyable.

 

I thought I would share my experiences of installation as it was ever-so slightly different (as I am sure are most installations) to the 'standard install' and I hoped that they might help someone else.

 

As per the topic, I have a fairly standard D630 with 2GB of RAM, intel graphics (1280 x 800) and the 2Ghz mobile CPU along with the Intel 4965 WiFi card. My workplaces had a lot of these and as they are being replaced there were a few spare, so they let me borrow one for a while to play with! I upgraded from the A13 BIOS to the A17 as I think I'd read that it always pays to be on the latest.

 

Until a week ago I'd never touched a Mac OS X machine (in fact I think the last Mac I used was a 66Mhz with OS7 on...). A guy at work needed some files recovering from a dead eMac and as I didn't have access to one but wanted to help, I started looking into OSX86. I actually installed 10.5.0 up to 10.5.6 on an Acer Aspire One at the weekend in order to recover the files which worked really well, but it got me really interested in what else I could get OS X running on!

 

After finding this site and then realising that I could get a D630 quite easily my first problem came in the form of not having an OS 10.6.x or OS 10.7.x machine to make the boot image with. This lead me to looking into installing it in VMWare, which as it turns out is reasonably easy. I used the instructions on this page :

 

http://www.windows7hacker.com/index.php/2011/09/how-to-install-fully-functional-mac-os-x-lion-virtual-machine-inside-windows-7/

 

I run Windows 7 64bit on an i5 with 8GB of RAM and the VM is very useable, although the graphics acceleration for VMWare doesn't work, so it's no good for 'heavy' use.

 

However, for use as a 'mule' to make bootable media, it's perfect. I used a 40GB external HDD that I simply attached in VMWare and then pointed the myHack tool at it. I had downloaded the Extra folder and told it to use that during the creation of the boot media, this seemed to work well. I used a 10.7.2 image to create my boot USB drive.

 

When I first tried to boot after creating the boot image the USB disk would flash for a bit and then the screen would go blank. After a couple of minutes I would get a Kernel Panic (KP I think the term is!). After a couple of these KP's I noticed that it was failing on the AirPort driver and remembered I'd seen something about disabling the WiFi in the BIOS, after I had done this it booted into the setup routine without issue. At this point I didn't have a mouse, the trackpad wouldn't work, I plugged in a USB mouse and continued the setup. I partitioned the internal disk with the disk manager and installed to this partition, took about 20 minutes. As advised I then booted from the external USB and used Chameleon to select my new install, it booted and talked me through the setup routine, the only odd thing is that it told me I didn't have a keyboard! Plugged in a USB one so it would carry on, and after that I could use the onboard keyboard. As per the instructions I used the myHack utility to fix the bootloader so I didn't need to be boot from USB. I didn't load the EDP at this point, but rebooted to make sure it worked, which it did! After a reboot I loaded the EDP which worked really well, thanks again to all that have contributed to that.

 

I hooked up the ethernet port to my router because of the lack of wireless and again this worked without issue. I updated iTunes without any problems but have held off on upgrading to 10.7.3 (any opinions on if this is a good idea?).

 

And so this is where I am currently:

 

Working

 

Video (720p works on Youtube, but I have to fix the CPU frequency with the voodoo tool or I get distortion)

Sound (see above)

Headphone port cuts out internal speakers, works as stereo

Volume buttons on the keyboard work, as does the mute button

Ambient light sensor

Brightness controls

USB Ports (tried an external HDD, USB pen drive, mouse, keyboard)

Keyboard (see above)

Trackpad (see above and below!)

Battery meter seems to be accurate, though is giving me 'Service Battery' warning, the laptop is 3.5 years old though so that might be legitimate?

 

Semi-working

 

Trackpad works, and buttons work, but when I look in settings in trackpad or mouse, it says I don't have one. I haven't tried all the options on the EDP yet though.

Sound - Fine as long as I used a fixed frequency for the CPU and didn't let it dynamically allocate the speed.

 

Not working

 

WiFi - And as I understand it, as I have the 4965 card I will need another one

'Nipple' in the middle of the keyboard

 

Not tested

 

DVD/CD Writer

External Display

Firewire

Inbuilt Mic

Mic Input

Modem (I put in a call to 1998, but no one was available for testing.. ;) )

Serial Port

 

Sorry for the long first post but hopefully it might help someone else out along the way. I will update if/when I test anything more or get one of the broadcom/dell cards. Are the 1390's still the recommended option?

 

Thanks again,

 

Dave

Link to comment
Share on other sites

One thing I have noticed isn't quite 'right' is that my 2GHz CPU shows up as 1.81 GHz in both 'About this Mac' and benchmark tools.

 

The benchmarks seem to suggest it is running as quick as it should be, and it 'feels' fine, but I wondered if anyone else had seen this and had a fix for it?

 

I don't have the speedstep stuff installed as it seemed to play about with the sound quality.

 

Cheers,

 

Dave

Link to comment
Share on other sites

 Share

×
×
  • Create New...