Jump to content

Dell 7280 - Almost Everything working.


Yomiro
 Share

Recommended Posts

Thanks for the guides and bootpacks.   I purchased a Dell 7280 and installed Catalina.  Everything is working except for:

 

1) I have not been able to get any sound device to show up. It should work since it's ALC256, I tried multiple layout-id.

2) Brigthness Keys are mapped to FN+B and FN+S instead of FN+UP and FN+DOWN  (not big deal)

3) HDMI out freezes the laptop or reboots.

4) Lid open/close does not work. 

---------------------------------------------------

 

Debug files attached.

debug_3360.zip

Link to comment
Share on other sites

  • Moderators

Try this, replace Config file, add SSDT-xx to Patched folder. Remove SSDT-HDEF.aml from Patched. It has layout-id set to 13 yet you have 14 set on your Config file. So it's conflicting.

The added SSDT-BRT6 might fix the Fn+F11 and Fn+F12 Brightness issue

The config is now setting audio to layoutID 21, if it still doesn't work, then switch it to 56, that should work.

If that still fails to grant you audio, you might want to remove FakePCIID_Intel_HDMI_Audio.kext from /L/E

 

7280_AudioFix.zip

Link to comment
Share on other sites

Thanks, YOU ARE DA MAN!!!

 

I had to do all 3 steps to get audio working

1) layout id 21

2) Remove SSDT-HDEF.aml

3) Remove FakePCIID_Intel_HDMI_Audio

 

Also your BRT6 SSDT fixed the brightness keys!!

 

My trackpad is flaky.  I believe its working like a mouse because trackpad is not detected in prefs panel.  Is there a good kext to use for I2C ALPS trackpad?

 

Thanks Again,

 

debug_29539.zip

Link to comment
Share on other sites

  • Moderators

found both in your kextcache log and IOReg file

For Trackpad, it's probably as good as it gets since its an Alps I2C, no support but only basic movement and maybe 2 fingers scrolling, 2 fingers right click and tab to drag.

 

Link to comment
Share on other sites

 Share

×
×
  • Create New...