Jump to content

E6540 continuity hassles...


appletechgeek
 Share

Recommended Posts

hello.

i got a dell e6540 here with a core i7 and 16 gb of ram running mac os mojave.

i replaced the 2007 airport card with a aw-cb160h card wich should be 100% supported in mac os.

after install i noticed only 2.4 ghz worked so i tossed in the following kexts in the system folder (it didnt appear to be working when it was put in clover instead)

the kext are BrcmPatchRAM2 airportbrcmfixup and bcrmfirmwarerepo

after those the 2.4 ghz 5 ghz and bluetooth started working but no continuity yet.

connecting my bluetooth headphones work fine. but sometimes disconnects and distorts (using 3 very short antennas as my laptop's atennas does not  fit the card without a dongle)

i did notice when i try to link my iphone x it wil connect for a second (tried bluetooth internet sharing too) and it discconects as "unable to connect" about 5 seconds after connection..

i tried changing my smbios version from a late 2013 to a mid 2014 macbook pro 15 inch with a matching serial number to the model but that does not appear to have fixed anything.

 

imessage works and so does recieving sms messages altho imessage seems to not always sync to the laptop  (it worked on the old airport card exact;y like this too)  also ignore the millions of google verification codes :P

if i try to use the continuity activation tool it reports as "mac os reports continuity as active already" 

 

any ideas to what i should do?

 

i'm going to buy a macbook tomorrow so i can start working on reinstalling hackintosh on the laptop freshly  but i suspect i wil run into the exact same situation as now.

 

thank you a lot in advance for your tips

 

 photo5857163536143332116.thumb.jpg.19cd7d9ea354a87b91ae7b42e3d5cd49.jpg

Link to comment
Share on other sites

 

the card itself is :BCM94360HMB

the bluetooth is BCM20702A0 according to system profiler 

if i google the model + bluetooth related hackintosh issues all the results i see is people solving it by adding the exact kexts i added to my machine.

i did noticed it somehow connected to my apple watch already.

i tried connecting it to my test phone and it connected but connection was lost after 5 seconds. 

 

 

photo5857163536143332125.jpg

photo5857163536143332126.jpg

photo5856975150287794735 (1).jpg

Link to comment
Share on other sites

  • Administrators

There are multiple versions of those kexts so you probably need to try a few. Also check what firmware version the card currently holds, then compare that with what the kexts you use actually contain. Rehabman posted detailed instructions and info on his related repo. Check those out.

Link to comment
Share on other sites

can i trust the system profiler in regard of finding out the firmware version?

 

also to get the old airport card working i had to extract dosdude's post patcher since this card was not supported anymore after capitan 

maybe the patcher moddified a driver that results into something. but i wil read trough his intructions 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...