Jump to content
PayPal donations: [email protected] ×

Recommended Posts

Also this time I have to thank you (Jake Lo and Hervè)!! Now I've solved. I tried to find out  some documentation about this update and found incorrect information.. sorry to all for that post. I've edited  my post deleting the wrong information.

Share this post


Link to post
Share on other sites

Hi, for correct audio output you need set layout-id correctly in config.plist device properties. 

 

I have a Dell 3490 and for this laptop I tested all layouts and for my case the better layout is 27  (15000000) and works all audio outputs/ inputs. but for your setup may be different. 

 

I use Catalina 10.15.6 and Clover 5119.

you don't need inser kext in L/E only the kext in EFI/CLOVER provided by Hervé.

 

Realtek ALC256 layout 1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34 and below (converted to HEX),  try layout-id in our config.plist > Devices > Properties and restart you laptop. One of this may be work if you use Clover pack #3  provided by Hervé

 

 01000000, 02000000, 03000000, 05000000, 07000000, 0B000000, 0D000000, 0F000000, 10000000, 15000000, 1B000000, 1C000000, 1D000000, 22000000

 

Leave "inject" in black/ null

245386261_CapturadeTela2020-08-16s13_40_06.thumb.png.473308da7759ba4e04db5a5898de4105.png

 

 

Update 19/08 For Dell Latitude 3490 Intel(R) Core(TM) i5-8250U CPU @ 1.60GHz (Brazil)

 

I Changed the layout ID to 13 or 56 if you use the latest ALC kext and used patched CodecCommander.kext With ALC256 based in this post https://techposts.org/fix-realtek-alc256-audio-macos-hackintosh/  and this  solve like a charm  my issue with Headphones in 10.15.6 (19G2021).

 

Clover+alcplugfix.zip

 

You need copy CodecCommander.ket from audio folder in pack  that I already patched with ALC256 to EFI/CLOVER/kext/Other/

Don't use other kext or SSDT in folder EFI/CLOVER of this pack if you are not sure about you system is a 3490.

 

Unzip ALCPlugFix.zip in your Download folder and use Hackintool > Tools  to mount in rw the / and then install the  ALCPlugFix according to  the tutorial in the link above using a double click in Install.command or via terminal. you can inspect the code if you want.

1463024942_CapturadeTela2020-08-19s22_16_27.thumb.png.d6a5aabd105e6c7851bcbd601074f1c3.png

 

 

You can enable again the Gatekeeper after install ALCPlugFix.

 

After restart the system, the fix is enabled every time you insert the headphones :-) . If does not work with layout 13, please try in other layout-id like 11 or 21.

 

604101261_CapturadeTela2020-08-19s22_31_09.thumb.png.b8e99696aa5edef6b66cd8d25aa86a19.png

Share this post


Link to post
Share on other sites

I resolved my issue for 10.15.6 changing the layout id to 27 for Latitude 3490 but in hex in config.plist. I wrote a topic in this thread  about this!

 

Share this post


Link to post
Share on other sites
Em 16/08/2020 às 13h58, juliano disse:

Oi!

você pode fornecer seu efi? Tenho esse mesmo notebook e gostaria de tentar instalar a catalina nele. Se eu posso ajudar? obrigado. Do brasil

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...