Jump to content

Reload kext's after sleep, app to do this?


pckrullenbol
 Share

Recommended Posts

Somewhere in the archives admin Leon mentions that problems with the trackpad after sleep can be solved by a certain app:

"I think you need to reload the kext after sleep, there is an app that automatically run a script after it resumes from sleep."

 

But where to find this app?

Link to comment
Share on other sites

  • Administrators

you have to create a shell script and run that ... eg.

 

sudo su

mkdir /scripts

cd /scripts

nano aftersleep.sh

 

type:

kextreload

 

press CTRL+O and CTRL+X .. and finally type:

 

chmod 777 /scripts/aftersleep.sh ... and then get sleepeanbler to load that shell script

 

 

... or something like that ;-)

Link to comment
Share on other sites

kextreload <path to kext>

... or something like that ;-)

 

I tried to get this working, but I'm afraid I need some extra help.

The instruction 'kextreload' does not exist, but 'kextunload' and 'kextload' are available.

I'm using Apple PS extensions (option 1) so I want after sleep this to happen:

kextunload /Extra/Extensions/ApplePS2Controller.kext

and then

kextload /Extra/Extensions/ApplePS2Controller.kext

 

When I try this in Terminal 'kextunload' does not seem to work (even with 'sudo') I get an error: "kext is in use or retained (cannot unload)"

OK, then I try kextload (with 'sudo'), the kext is getting (re)loaded without errors, but when I do this after sleep, the problem with the not working trackpad still exists.

 

What do I need to do to het this working?

Link to comment
Share on other sites

You have D430 like me, use option no 2. instead - the debug version.. it even have side scroll

 

Option 2 is slow as hell! Even with the extra VoodooPS PrefPane.

I can't believe people are really like using this, or do I have different hardware?

 

But one good thing about this driver is that the trackpad is working correctly after wake-up... :)

Link to comment
Share on other sites

Connect an external USB mouse, set the speed to maximum, restart on test the trackpad

 

I tried this trick, and now have a D430 with a super slow trackpad (and a super quick mouse when I reconnect it)…

Exactly what I expected, but should it make a difference?

Link to comment
Share on other sites

 Share

×
×
  • Create New...