Jump to content

D830 x3100 woes


goatman
 Share

Recommended Posts

I've tried everything I could find to resolve the blank screen under 32 bit lion.

specs. D830 intel centino Duo circa 2005, with service tag= 9TD62D1

cpu= c2d 2.2ghz each T7300

Graphics= Intel 64mb gm965/gmax3100 2a02:8086 EDID= Manufacturer name- AUO Prod Id=2274 SN=0 Week of manufacter=1 year=2006 EDID ver=V1.3 # of extrnl flags=0 Display size=15.4 Video input def=Digital Signal DFP1X comp= False Type=RGB Pixel clock=71.26mhz

What works:

Myhack 2.2 generic /extra and retail 10.7 final DVD.

64 bit boot= X3100 is recognized in system profiler. Graphics unsupported at vesa 3 generic with res at 1280x800x32 (changed in bootloader plist). No QE,CI, or OGL. Have desktop and all seems to work except app's requiring QE,CI or OGL. Intel wifi no kexts (expected). Have audio HDA working, GB ethernet working. KB and Track pad working with alps supplied by installer. USb,cd RW/DVD rom and Firewire working, both will boot from external drives.

Fixes I tried. I tried to find a 64 bit x3100 kext that would work. None would load, failing 64 bit dependencies.

 

32 bit boot= Boots to blank screen. All attempts to fix have failed. Tried 2.2 and 1.9.2 edp's. decompiled dsdt and removed crt, no change. Tried DSDTse blackout fix no change. Currently trying to recompile dsdtse fix for x3100 laptop hack (15) but it error's out with unexpected open bracket ({)on line something. If I remove it more errors are generated, so I gave up on that. All other dsdt and plist and kext hacks I have googled have failed.

DSDT & EDID info.

D830 DSDT&EDID.zip

 

Edit: I did try edp 2.2 for d830, d630. Oddly enough the d830 nvidia worked the best but still blank screen under 32 bit. I also tried all of the x3100 kexts and dsdt's claimed to work/fix the d830. I must have one of the older ones. If the x3100 64 bit kext in SL might work I will try it.

Edited the the 965/x3100 id's. It is vid=8086 and DD=2A02

Edited by goatman
Link to comment
Share on other sites

have you tried GraphicsEnabler=yes at boot? if not try with a newer chameleon like the one in myhack2.2 or higher

Yes, I did try edp 2.2 for d830, d630. Oddly enough the d830 nvidia worked the best but still blank screen under 32 bit.

Link to comment
Share on other sites

lol... i meant at the chameleon boot prompt type in GraphicsEnabler=yes hopefully your chameleon boot loader is higher than 1819

if that docent help try with the no option

chameleon 2.1 svn 1828 in my hack 2.2 and yes I tried both ways. I think the only thing I have not tried is the edid mod for my dsdt, which I extracted both under xp. Also lion with myhack 2.2 install will boot 64 bit without the dsdt or boot plist and everything works but the x3100 kext (not 64 bit). That one 64 bit kext is what I really need. I will settle for a 32 bit lion or SL.

In the past I have installed 10.5.8 in a dell gx260,gx270,gx280, and a gx620, all working fine. They are not vanilla installs and a little different than these intel installs.

Link to comment
Share on other sites

  • Administrators

well as there are no 64 bit x3100 kexts what happens is osx goes into vesa mode from mach_kernel so that is why it shows that the kext is not loaded but works without acceleration. what are you using for a boot.plist that it's loading in 64 by default? or have you modified it to do that? another thing you can try at chameleon boot is UseKernelCache=no just in case it's a kext not loading properly or a corrupted cache.

Link to comment
Share on other sites

i've used -f to ignore the boot cache in 64 bit and 32 bit but the kext always fails dependencies, because it is not a 64 bit kext. in 32 bit mode the kext will load, (as it shows in the log) and will make it to the desktop but the screen turns blank. when booting I see the grey apple and spinning progress indicator, but when the screen should turn white and then load the desktop it turns blank instead of white.

I have read that some info needs to be transfered from the edid to the dsdt to properly use the screen of my d830. chameleon shows (and xp with updated intel driver) that the max resolution is 1280x800 with 64mb of vram, pretty old and probably the first model d830 to come out.

Link to comment
Share on other sites

A step in the right direction!! Went to tonycrap in search of a dsdt edid guide. No guide, but did find some info on edid and dsdt editing. Deleted crt,tv, and everything but vid and lcd entries. Was getting black screen, now I get left side white and right side black with horizontal colored lines! Something new to work with. I will try to add the edid raw data to the dsdt.

Link to comment
Share on other sites

you sure you don't have a high res model check in bios? or the boot graphics set too high in the Boot.plist try like a 1024x768x32?

Bios says Intel crestline Graphics controler (GMA965), video Bios=1588, video ram= 8mb, Panel type= 15.4 wide XGA, Native rez= 1280x800.

Chameleon bootloader says video info= 1280x800x32 max rez.

System profiler says= Vid=0x8086, DevID= 0x2a02, Rev= 0x000c.

EDID says Manufacturer= AUO, Product ID= 2274, EDID ver= 1.3

D830 Service tag= 9TD62D1

I have the rez set at 1280x800x32 in chameleon boot plist. I have changed it to 1024x768 and 800x600. still no desktop. All of the bootpacks and boot plists I have tried all have the rez set at 19200x????.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...