Jump to content

No Sound on Inspiron 3542 after 10.15.4 to 10.15.5 update


spidey123
 Share

Recommended Posts

Hi guys, I just took the latest update for Catalina and lost my sound, which is normal until I reinstall my AppleHDA.kext, but even after re-installing my custom AppleHDA.kext (I have done this for the past two years) and installing the newest Lilu and Whatevergreen Kexts.  I still cannot get sound.  First time this has ever happened.  Sound was perfect on Catalina 10.15.4  

 

Did the update change the way sound kext work?

 

Update.  I reinstalled Vanilla AppleHDA 10.15.5 and added latest AppleALC to /EFi/Clover/Kexts/  and all is well again.   I guess I missed that you didnt need a custom AppleHDA kext anymore.  Probably been that way for a long time.  

Link to comment
Share on other sites

@spidey123 It has. :)  Patching the original AppleHDA kext is a pretty bad way to get sound working. :)) But it is/was commonly used on other forums for a while. So, I get where you're coming from. But also, as you noticed, you don't need that anymore. With this method (Lilu + AppleALC + layout-id), AppleHDA stays the same and the updates don't break sound anymore. 

 

Enjoy!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...