Jump to content
PayPal donations: [email protected] ×
LyonLeBrun

AW-CE123H not working in Catalina

Recommended Posts

IOReg looks good except no wifi loaded.

You have darwin 19.6.0, so I guess you're running Catalina 10.15.6. No need to install IO80211Family.kext (Mojave) to /L/E. Remove it, repair permissions and rebuild cache. Make sure you have vanilla IO80211Family.kext of Catalina in /S/L/E (untouched). 

If that still not working, try at OC picker, select 'Reset NVRam'. 

The AW-CE123H is the same as the DW1550 and it's working fine on my E7440.

Share this post


Link to post
Share on other sites

Thanks for the advice and updated config.plist. Wireless still doesn't work, but the symptoms have changed.

 

Now the Wi-Fi icon is a black-outlined fan shape. Selecting "Turn Wi-Fi On" causes it to go to grey fan for a few seconds before turn to a black-outline fan again.

 

System Preferences -> Network - Wi-Fi shows a "Turn Wi-Fi on" button, but that has no effect. I attach the latest IORegistryExplorer output.

 

Here's what I did:

  • Removed IO80211Family.kext from /L/E
  • Verified that both IO80211Family.kext and IO80211FamilyV2.kext (untouched) are present in /S/L/E
  • Repaired permissions, rebuilt caches
  • Restarted
  • When the OC Picker came up, used Reset NVRAM
  • Copied your newest config.pilst to /EFI/EFI/OC (Note: the only changes from your original OC EFI version seem to be s/Compatible/compatible/, s/14e4,43b1/pci14e4,43a0/, s/BCM4331/BCM4352/ in "model", and to move the "AirportBrcmFixup.kext" bundle path above the "AirportBrcmFixup.kext/Contents/Plugins/AirPortBrcm4360_Injector.kext". Is this correct?)
  • Restarted - and now have the behavior described above

I agree the problem could be elsewhere - what other information can I provide? Many thanks.

Rich's Dell E7440-14Sep2020.ioreg.zip

Share this post


Link to post
Share on other sites

@LyonLeBrun

Forgot to mention, you need to disable SIP. In order to do that you need to boot to the recovery mode just like a real Mac. Run

csrutil disable

reboot to Catalina, run

sudo kextcache -i /

reboot back to recovery mode, turn back on SIP

csrutil enable

reboot

Share this post


Link to post
Share on other sites

No change to the behavior (I still have the black outline icon. Choosing "Turn Wi-Fi On" causes it to go to grey fan, then the black outline again.) I used Utilities -> Terminal from Recovery mode to disable SIP (with csrutil disable), then booted back to Catalina disk and ran the kextcache command.

 

I ran three variations on the kextcache command, since the first didn't seem as if it worked right:

  • sudo kextcache -u / (gave Warning: /AppleInternal/Library/Extensions: No such file or directory)
  • sudo kextcache -Boot -U / (gave message that everything was up to date - I will note that earlier invocations also gave this same "up to date" result) and
  • sudo kextcache -i / (appears to have worked without incident)

(I am hopeful that the second and third commands didn't cancel out the first...) Here's the output:

[email protected] github % sudo kextcache -u /     
kextcache -u /
Warning: /AppleInternal/Library/Extensions: No such file or directory

[email protected] github % sudo kextcache -Boot -U /
kextcache -Boot -U /
kext allow list already up-to-date for boot FDFD814E-85FB-47D0-9042-6CC5576BE60C

[email protected] github % sudo kextcache -i /
kextcache -i /
kextcache -arch x86_64 -local-root -all-loaded -kernel /System/Library/Kernels/kernel -prelinked-kernel /Library/Apple/System/Library/PrelinkedKernels/prelinkedkernel -volume-root / /Library/Extensions /AppleInternal/Library/Extensions /Library/Apple/System/Library/Extensions /System/Library/Extensions
KernelCache ID: E9A7E7FBE6144200232AC43CBC44FB07
[email protected] github % 

 

I then rebooted back to recovery mode, used csrutil enable, and then rebooted back to Catalina. That's where things stand with the black-outline Wi-Fi icon.

 

I'm still game to try other solutions/dig out other troubleshooting info. Thanks again.

Share this post


Link to post
Share on other sites

Go to Network preferences. Click on the + sign on the bottom right.

In the Interface drop down arrow, do you see Wi-Fi as an option?

Share this post


Link to post
Share on other sites

Yes. See the Network Preferences movie on Youtube.

 

I was slightly surprised to see the OpenWrt5 SSID listed - this installation has never successfully been on Wi-Fi, yet that's one (of *two* SSIDs at my home...) Thanks.

 

Share this post


Link to post
Share on other sites

I should also note the my internal drive's top-level /EFI folder has a number of files seemingly created for each boot with a filename of opencore-yyyy-mm-dd-hhmmss.txt, with this data in them:

 

00:000 00:000 Dependency com.apple.iokit.IOHIDSystem fallback to com.apple.iokit.IOHIDFamily succeeded. Please fix your kext!
00:185 00:185 Dependency com.apple.iokit.IOHIDSystem fallback to com.apple.iokit.IOHIDFamily succeeded. Please fix your kext!

opencore-2020-09-14-163048.txt.zip

Share this post


Link to post
Share on other sites

Ok, that's a good sign your wifi should be working, just not able to turn it on. 

Check your BIOS, do you have WWAN/WiGig/WLAN/Bluetooth Switch enable under Wireless?

On the right side of your laptop, there's a toggle switch. Make sure it's set to ON (not showing red).

 

The above error is easy to fix. Navigate to the VoodooPS2ControllerR6/contents/Plugins/

There are 2 kexts, open info.plist from both plugins and change com.apple.iokit.IOHIDSystem to com.apple.iokit.IOHIDFamily under OSBundleLibraries

Share this post


Link to post
Share on other sites

×
×
  • Create New...