Jump to content

Wolfdale C2D desktop: freeze on booting Big Sur with OpenCore


Recommended Posts

  • Administrators
3 hours ago, [email protected] said:

after installing, I'm stopped here.

Can you clarify the situation regarding this Big Sur attempt?

 

Your system freezes whilst booting the USB installer?

You have completed the 1st stage of initial installation and system freezes on 1st reboot?

You have fully completed the installation and all subsequent reboots freeze as per screenshot?

 

To be honest, I don't even know if Big Sur can be succesfully installed on a Wolfdale platform; I only briefly tried on my old Vostro 200 and failed. Big Sur won't support your old Telsa Geforce 210 card for sure, it'll have to go...

Link to post
Share on other sites

To install, I used a sata to usb adapter and after install, if I keep using the hard disk externally, it boot with no error; if instead I insert the hard disk directly, it tells me the error, as in the photo

 

I would like to try using the dortania guide patcher for my nvidia:

https://dortania.github.io/OpenCore-Post-Install/gpu-patching/nvidia-patching/

Link to post
Share on other sites

I tried this patch, but nothing:

fix hotplug ICH10 for 11.0.1
Identifier: com.apple.driver.AppleAHCIPort
Find: 750c81e2bf7fffff
Replace: eb0c81e2bf7fffff
MinKernel & MaxKernel: 20.1.0

Do you recommend any kext or patches in particular?

 

There is no AHCI option in my bios. That's why I installed it using a sata to usb adapter

Link to post
Share on other sites
  • Administrators

These (old) HotPlugging patches for AHCI disks will indeed be of no use if there is no initial support for your ICH10 SATA controller in AHCI mode. Their own stated description says all about their purpose...

 

P43 chipset supports ICH10 (base) and ICH10R controller, so depending on which you have you could be lucky or unlucky. As described in ICH10 datasheet, ICH10 (base) does not natively support AHCI capability; it's conditional... Booting with your disk externally attached to a USB port, you may use Terminal commands to read the various registers that report of disk mode capability and status (you'll need to install tools such as the old lspci toolkit if you can find such stuff in 64bit). But even if the controller were to be returned as AHCI capable, you may find it difficult if not impossible to set it so given that BIOS does not offer the mode...

 

This reminds me of the (fun) days when several of us Hackintoshers were trying to set the ICH7-M controller of the good old Latitude D620/D820 laptops to AHCI but miserably failed. BIOS would not offer the option it even if the controller was technically capable. You'd find threads/posts about this here with a little search.

 

Anyhow, you could easily check the operating mode through any existing Windows or OS X/macOS installation. If disk runs in AHCI mode, it'll show in Windows Device Manager or SysInfo->Hardware->SATA. If your ICH10 only operates in IDE mode, you'll find AppleAHCIPort won't load, so HotPlug patch won't even apply...

 

Rest assured that old Intel I/O controllers from ICH8 to ICH10 remain supported in Big Sur in AHCI mode (cf. Info.plist of AppleAHCIPort kext). It's a long time since I last checked but 'm pretty sure there's been no native support for legacy IDE mode in macOS these last few years in which case you could try and inject one of those old AppleIntelPIIXATA kexts from a previous version; no guarantee whatsoever that it would work... All in all, I'm pretty certain that the bottom line is: no AHCI, no Big Sur on internal disk.

 

Last macOS version with an AppleIntelPIIXATA kext was Mojave 10.14.6; see attached IOATAFamily kext where you'll find the PlugIn; but no entry for ICH10 so you may have to create/add one...

IOATAFamily.kext_Moj10.14.6.zip

 

Of course, the best solution would be to opt for one of those supported PCIe SATA-III add-on controller cards. Would avoid all issues and give you full 6.0Gbits/s speed (ICH10 is SATA-II, i.e. 3.0Gbits/s only).

 

Final word about the nVidia patching documentation you've referred to: it's applicable to nVidia dGPUs that are supported by the underlying OS! Not the case here and you must know that Tesla GPUs were dropped with Mojave which means there are no longer any drivers for these... Replace your card if you want to run Catalina/Big Sur.

Link to post
Share on other sites
×
×
  • Create New...