Jump to content

Dell Latitude E7470: Brightness Control under Mojave

Recommended Posts

I hope it's appropriate to start a topic on this...I found some slightly similar threads but none that seem quite like this! I have my Dell E7470 running Mojave (10.14.6) super smoothly, with the exception being that Brightness Control only works after Sleep mode.  ie. if I select Sleep from Apple menu, wait about 15 seconds for it to 'fully' go to sleep, on reawakening brightness control works normally with fn-S and fn-B. Before waking from sleep, fn-S and fn-B bring up the Apple brightness graphic with the notches, but display will only set to full brightness (100%) or off (0%). I have combed through so many different solutions and websites for clues but I keep coming up against this dead end and I'm far from an expert on this stuff. Any help would be greatly appreciated!


Here I've attached my Clover folder.


And hardware info:

  • CPU : 6th gen Intel Core i7-6600U 2.6GHz 
  • Graphics: Intel HD Graphics 520
  • Display: 14.0”, Full HD (1920 x 1080), IPS
  • Disk: 256GB SATA SSD
  • Wireless: Intel Dual Band Wireless-AC 8260



Link to post
Share on other sites
  • Moderators

From the files you attached, you should be able to control brightness with Fn+F11 and Fn+F12. It's probably issue with NVRAM

Try testing from terminal. If you don't get an output after the second command, then NVRam is not working

sudo nvram test=NVRamDetected

sudo nvram -p | grep 'test'


Also the SSDT.aml is not for your system, it's for an i5-6300u. Also you don't need it since it's already have pluginType enabled in the Config file

Link to post
Share on other sites

FnF11 and FnF12 do nothing.  Fn-S and Fn-B still show brightness indicator, but only change brightness after sleep.


Deleted ssdt.aml , still no luck.


CLOVER.zip'NVRAM Detected' after those lines.


I've tried a few changes in config as well so here's an updated clover folder.


Thanks so much for getting back to me!


Link to post
Share on other sites

If it changes anything - I realized just now that brightness keys actually do work after booting in the Clover menu, using Fn-11 and Fn-12.  After loading the osx partition and Mojave, Fn-S and Fn-B bring up the mac os brightness up/down graphic indicator on the screen. However actual brightness control only works after waking from Sleep as described above.  Does this mean something in the Mojave loading process is messing with things?  Conflicting kexts in Sys/Lib/Extensions or something? Any help appreciated!  Most up to date clover folder attached. :)


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...