Jump to content

Latitude 5490: Headphone jack and Touchpad not working


Recommended Posts

Please help I have been working on this for 6 hours but no luck and I'm going crazy


I prepared a USB with Catalina and OpenCore for my Dell Latitude 5490. I can boot into macOS, and it takes me to the macOS recovery page. My touchpad doesn't work and the cursor is stuck in the top left corner. I can select options using my keyboard. 


Here's what I found out/tried:
1. Removing VoodooPS2 results in booting straight to a magc mouse logo, which probably means that it doesn't detect any input device. My keyboard also doesn't work because when I press the Caps-Lock button, the light doesn't turn on.
2. Adding VoodooPS2 gets me past that screen and takes me to macOS recovery. The keyboard works because I can use the arrow keys to move up and down and the Caps-lock light turns on.
3. Tried adding VoodooL2C and just the L2C HID satellite kext but that didn't work.
4. Added all the VoodooL2C satellite kexts but that did not work either.
5. Tried both with and without the PS2mouse EFI file in the Drivers folder that came with the OpenCore package.


Also, My headphones when plugged in only give me a static noise and I can't hear any audio. Speakers seem to be working fine though.


Please advise on what to do. Any help is greatly appreciated.


EDIT: EFI folder https://drive.google.com/drive/folders/1zJ8Eb-H7s6vS6nmEOYuivV_49cDqih7x?usp=sharing

Link to comment
Share on other sites

Hey man thanks for the reply. The EFI folder I uploaded is about 1 week old and I've added many kexts since then. So I'm not sure if your config would work with my updated EFI, could you please update the config according to this EFI folder:




Really appreciate it brother

Link to comment
Share on other sites

  • Create New...