Jump to content

[SOLVED]Can't install alc-fix on Big Sur 11.1


Recommended Posts

Hi everybody. I'm following Jake Lo guide to install Big Sur 11.1 (Dell Latitude E7440) without issues, but when i'm going to install alc_fix from Download folder, terminal says: "zsh: no such file or directory: ./install". Thought it was due to using szh instead of bash and tried with a bash session with ./install.sh, and it start to install: "Installing ALCpluginFix v.1.7", but then it says: "mkdir: /usr/local/bin/: Permission denied", ask for the password but can't create the folder. I even created manually the folder /usr/local/bin with sudo mkdir and then I got to install ALC_Fix, but after rebooting system, I lost the sound (no sound device). I'm sure I'm doing something wrong... Any idea? Thanks a lot.



Link to comment
Share on other sites

Ok. Disabling SIP can be done typing "csrutil disable" from Terminal in Recovery mode, but I'm not sure how to getting in Recovery mode. ¿Do I have to delete HideAuxiliary from kernel boot properties in Opencore config.plist and I will see Recovery entry in Picker or there is a way to get all the entries (maybe pressing spacebar)? I can't test it because I won't have the laptop until tomorrow. Thanks again for helping me with that.



Link to comment
Share on other sites

Thanks very much, Jake Lo. It's done and working now. I will describe te entire process I followed under Big Sur 11.1  just in case someone has the same problem:


1. Reboot system with Recovery partition. If you don't see Recovery in Opencore Picker, press spacebar and you will see it.

2. In Recovery screen, click Tools>Terminal and write:


csrutil disable


3. Press RETURN on your keyboard and reboot system in normal mode (main OS X partition).


4. Download alc_fix.zip. Open Download folder and unzip file.


5. Open Terminal and open a BASH session typing




6. Press RETURN


7. type in Terminal with Return after every order


cd Downloads

cd alc_fix

sudo ./install.sh


8. After the last Return you will see a message in Terminal, ending with "Done!"


9. Type in Terminal




10. Press Return and close Terminal


11. Reboot again in Recovery mode pressing spacebar if necesary.


12. In Recovery Screen, click Tools>Terminal and write:


csrutil enable


13. Press RETURN and reboot system in normal mode again.


14. After writing your password you will see a message saying: "AlcplugFix is an app downloaded from INTERNET. Are you sure you wnat to open it?"


15. Choose OPEN button and that's all.


I hope it will be useful. Thanks to Jake Lo. As usual, he solved the trouble.




  • Thanks 1
Link to comment
Share on other sites

  • Create New...