Jump to content

Dell Precision 7510 - OpenCore boot problem


Recommended Posts

  • Replies 23
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

If you're using my 7510 bootpack from the guide, it's already included under /EFI/Boot/DVMT Modify grub.cfg and change  setup_var 0x432 0x3 to  setup_var 0x432 0x4 Save and re

Posted Images

OK - my mistake on the last screenshot. Too many config.plist files floating about.

 

The OC Config LHS, Clover Config RHS Below:

 

1897021079_ScreenShot2021-05-04at22_37_30.thumb.png.2721f82e8f5b7e2401dc2162589339b3.png

 

So can confirm: 

 

AAPL,ig-platform-id =05003B19 

device-id = 1B190000 

OK - I set back to MacBookPro13,1 since this is what I have been using with Clover and also set the boot flag - wegnoegpu since this has also been in use. 

 

Are all boot flags from Clover transferable to OC ? 

 

Here's what I know see when I try to boot:

1007854801_Boot-AlliGPUprops-wegnoegpuset.thumb.jpeg.32ade06dd7b667c0c1b42489e2c48f38.jpeg

 

Error shown:

 

Lilu patcher: @ failed to solve __ZN31AppleIntelFramebufferController17IsTypeConlySystemEv, err2
WhateverGreen igfx: @ failed to route IstypeCOnlySystem

 

EDIT: As far as I can tell from here: https://www.insanelymac.com/forum/topic/325987-whatevergreen-support-topic/page/55/

 

The above might not be causing issue.

Link to post
Share on other sites
  • Moderators

If you're using my 7510 bootpack from the guide, it's already included under /EFI/Boot/DVMT

Modify grub.cfg and change 

setup_var 0x432 0x3

to 

setup_var 0x432 0x4

Save and reboot

Go to the BIOS

Create a new boot option, call it DVMT or whatever you like

Point it to /EFI/Boot/DVMT/Bootx64.efi

Save and reboot, press F12

Select the new boot option DVMT or whatever you assign it

At the grub shell, select Option 1 for "#1 iGPU-only configuration. No dGPU. "

 

Or you could download modGRUBShell.efi, add it to drivers folder and enable it in the Config file

At bootup, press spacebar to review the boot option. Select it to boot to the Grub Shell and run the command

setup_var 0x432 0x4

  • Like 1
Link to post
Share on other sites

HI @Jake Lo - finally moved forward and have laptop graphics is working. 

 

340714680_ScreenShot2021-05-07at16_19_03.thumb.png.244160bca64cda8d67e318f0f4f510d6.png

 

 

 

 

 

 

 

 

 

 

 

I am not sure the "setup_var 0x432 0x4" changed anything however I downloaded your boot pack (many thanks) and made some small adjustments and things kicked in. I've attached the config.plist that shows the changes made.

 

They are essentially now looking like this:

 

1965399799_ScreenShot2021-05-07at16_24_04.thumb.png.011e9cb1c7c93d70e55f56db72291889.png

 

What doesn't yet work is any of the external ports.

 

 

 

 

config.plist.zip

Link to post
Share on other sites
  • Moderators

In the BIOS, under graphics, there should be an option next to "enable switchable graphics", to not forward external graphics to the DGPU. 

I can't remember the exact wording, I don't have the laptop with me now.

 

Found this

Make sure it's disabled

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...