Jump to content

macOS doesn’t boot with boot-args


Recommended Posts

Yesterday I tried to install macOS 12 and to do so I had to use -v and -lilubetaall. By doing so, I noticed that neither Monterey nor Big Sur (that works fine without that boot-args) boot. I tried to boot Big Sur with -v only and not even in that case it boots.



ASUS Laptop TP550LJ

Intel i5 5500HD

Nvidia 920m


I linked my EFI + boot logs from booting Big Sur



Link to comment
Share on other sites

  • Administrators

The only strange/incorrect things I notice are that:

  1. you inject CpuTscSync kext for your CPU. You failed to provide details specs about it, so can't say more but I doubt you'd need this on a dual or quad core processor. I'd disable this.
  2. you use MBA8,1 SMBIOS which, imo, is entirely inappropriate for your Broadwell laptop given that it's an Amber Lake Y/UHD617 Mac; you should have been using MBA7,x SMBIOS knowing that MBP12,1 is effectively the norm for Broadwell/HD5x00-6x00 laptops.

Also, given that you appear to run on the Intel HD5x00 iGPU, why don't you disable the nVidia dGPU? If you do not use it, it's better to disable it to avoid draining your battery unnecessarily.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...