Jump to content

Fresh setup - no wifi or ethernet


Recommended Posts

OK, I tried a update of EDP on my fully working D430 (10.7.3) and I just kept getting KP's and couldn't fix no matter what I did. So as the laptop has nothing critical on it I decided to create a new USB install sick (Lion) using latest myhack (3.1.2) and latest bootpack - just so I could try out the latest versions, get up to 10.7.4 and try out the new swanky OSXL instructions.


USB stick setup went fine (replaced Extra as per OSXL instructions using myhack interface).


Install went fine.


Before doing EDP build I applied 10.7.4 combo update I had downloaded earlier. Then I did a EDP build and rebooted.


All was good - apart from WIFI not working (ethernet was OK). So I downloaded all other updates and rebooted. All OK.


Then I got around to fixing the WIFI which I thought would be a quick job (had been in the past).


Applied ionetworkingfamily and io80211 kext's using kext helper (used the ones I had used when fixing wifi on my previous 10.7.3 builds - although I'm sure I only applied one of them in the past but latest post I found mentioned adding both?) - rebooted and wifi symbol appears but says no hardware installed! And the ethernet no longer works! In Network settings pref pane I get no ethernet or wifi when clicking + to add services. Only thing I can add is my WWAN card - which even if I setup I couldn't use as no 2g/3g signal where I am at the moment)


Checked the obvious (WIFI switch and BIOS - WIFI is on).


Did a full myfix - no difference.


Did a new EDP build and rebooted - just the same (I was hoping this would at least get me ethernet back).


I'm sure I'm missing something obvious here - any help gratefully received.


Thanks in advance


P.S. Only thing that seemed to be glaringly missing in the OSXL instructions was any mention of updates - somewhere between 2 and 3 on this page http://www.osxlatitude.com/edp/post-installation/ it needs to have a section on updating from 10.7 to whatever combo update is available as doing the 10.7.4 update after EDP build is going to break it.


Also thought WIFI would get sorted by the latest EDP as well - or is this an issue due to amount of different WIFI cards?

Link to comment
Share on other sites

yeah the wifi is a user supplied part as most latitudes are centrino with intel wifi.... put your wifi kext in E/E and run myfix from the myhack app


Cheers, tried and same result. Tried quick and full my fix. Both kexts now exist in e/e and s/l/e - anything else I could try?

Link to comment
Share on other sites

Hi bronxteck, yes switch and bios ok. All was fine before wipe and new setup using all new myhack and edp as above. Just replied to another poster about some kext they used to get wifi working. Will see how that goes.

Link to comment
Share on other sites

Well that kext was no good (a broadcom one from SL).


So after much more kext shuffling, installing and myhack fixes - I thought this is just wasting time.


So I did a fresh install again:


> Used new USB stick as before (built with latest myhack and D430 bootpack).

> After 10.7 initial Apple setup I did a copy of my original io80211familykext into extra/extensions and did a myfix quick and wifi worked after reboot - so card proved to be fine.

> Then did a install of latest EDP - but didn't do build

> Install of 10.7.4 combo - didn't restart

> New build using EDP - D430 default config

> Reboot - wifi broke

> Did a copy of my original io80211familykext into extra/extensions again and did a myfix quick and wifi worked after reboot :-)


So I'm on 10.7.4 with WIFI and ethernet working - so I must of messed up originally with a install of wrong kext or some update broke it.


Just one more question - I now have 6 updates available - which normally I wouldn't worry too much about - but I don't want to break it again - so iTunes/Safari/RDP update/flashback removal tool I'm fine with but what about the AirPort Utility and MAC OS X 10.7.4 supplemental updates (the 10.7.4 looks harmless but the airport one makes me nervous) - any experiences of these updates?



Link to comment
Share on other sites

i experienced a similar issue with my bluetooth adapter... it would show as on but mot connect to anything, fresh install and now it works great, weird


Thanks again - did you apply the airport and 10.7.4 supplemental update via software update?

Link to comment
Share on other sites

  • Create New...