Jump to content

E6440: issues after installing Big Sur


macostrial099
 Share

Recommended Posts

Hi,

After successful installation of Big Sur, and updated the USB drive, most thing are working except the following:

HDMI

Audio Jack

 

However, my Windows Boot Manager disappeared, I tried to restore the original EFI, it did not work, it seems it is a setting issue, I reinserted the new efi back.

My system setting:

Dell E6440

Intel i5 dual core M 4310

Intel HD Graphics 4600

Windows 10

 

 

The efi is in GitHub link! even after I removed some images from resources, it is still than that of allowed limit here.

https://github.com/learnseq/MacOse6440/blob/main/EFI updated 08152021.zip

 

I really need the dual boot OpenCore, I do use some softwares that are not available on Mac! 

 

Thank you in advance!

NB: I tried to update my profile but it won't let me go past the photo step!

 

 

Link to comment
Share on other sites

  • Moderators

Your Audio folder and AirportItlwm.kext are taking up space.

Your Config file and the ACPI folder does not correspond. ACPI should patched DSDT and SSDT, your config shows patched SSDT's.

For dual boot, you're missing the Microsoft folder, you'll need to restore that into the EFI folder.

HDMI looks like it's been enabled in the config file, for audio jack, you'll need to add CodecCommander.kext

 

Your hardware profile can be added to your signature file

  • Like 1
Link to comment
Share on other sites

Thank you so much Jake Lo for going through my efi! I appreciate your help!

 

 

I found a copy of the folder and pasted it in the efi, however; I'm getting error that windows not loading!🥶

I had, in the beginning dual boot working smoothly, but after I tried to fix the USB issue trying, to fix the touchpad issue(finger palm), and downloaded voodoo file from one post on this forum, after replacing it in efi and rebooting, it disappeared.

I removed the DSDT and I did not notice any effect so far! I followed partially the instructions on one of the post in this forum, it shows how to fix the USB issue touchpad issue.

HDMI does not even detect the connection! On windows it does, but on Big Sur, it doesn't!

Is CodecCommander.kext machine specific or is general?

Don't mind me asking so many question, I feel kind of lost when the windows boot disappeared!

Edited by Hervé
Removed unnecessary quoting
Link to comment
Share on other sites

  • Moderators

Windows won't boot or BSOD?

BSOD is normal when booting via OpenCore if you don't have your SSDT patched correctly since OC is loading the SSDT into Windows or any other OS you have installed.

If you press F12 and select Windows Boot Manager to boot, you won't have this issue.

Your Config shows you have SSDT-SMBUS, SSDT-XOSI,SSDT-PNLF.aml etc etc yet those don't exist in your ACPI folder, so I amazed you're able to boot your MacOS at all.

Looks like you're combining several old and new bootpack together. You should get that sorted out 1st unless you're posting the wrong files above.

CodecCommander is not machine specific, it's main purpose is to fix audio issue like headphone detection or audio resume after wake from sleep for some codec.

Link to comment
Share on other sites

Thank you for pointing out that I should have "SSDT-SMBUS, SSDT-XOSI,SSDT-PNLF.aml etc etc " before I wanted the USB fix, I did not have these nor their setting in config file.

Before the issue started when I press F12, I used to see three options: hard drive, EFI and Windows Boot Manager, but now I only see the MacOs drive.

I attached two photos, the first I just restored the windows boot folder to efi, the second the kind of error that I'm getting if I select windows.

 

IMG_4880.JPG

IMG_4879.JPG

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...