Jump to content

Bangho BES-1308 - Battery status, trackpad and webcam not working


elBuey
 Share

Recommended Posts

Hello guys,

    I've successfully installed Big Sur 11.5.2 on a Bangho BES 1308 laptop. Its specs are the following:

Processor: Intel i5 3320M (Ivy Bridge)
Chipset: C216
WiFi: Intel Centrino Advanced-N 6235
Sound: 7 Series(C216 Chipset Family High Definition Audio
Ethernet: Intel (R) 82579M
Display: Intel HD Graphics 4000

 

    There are 3 issues that still bother me a bit:

1- Battery reading is not working, not shown at all. In fact, "Battery" is not even shown in System Preferences.
2- The touchpad is not working
3- The webcam is not working

    I am attaching the EFI folder I am using, inside which you can also find the DSDT dump.

    Any suggestions will be much appreciated.

    Thanks in advance.

EFI.zip

Link to comment
Share on other sites

  • Moderators

1) you'll need to patch your Battery - or try ECEnabler.kext

2) you'll need to know your hardware, what touchpad is it? synaptics, Alps, Elantech ...other unknown

3) you'll need to patch for USB, try enabling XhciPortLimit since you have USBInjectAll.kext installed

Link to comment
Share on other sites

Thank you very much, Jake!

 

1- I've tried ECEnabler, and it hasn't made any difference. I've never heard about patching battery, is there an instructive I could follow you can share with me?

2- Is there any software you can suggest for getting the full specs of the hardware?

3- I'll try and let you know.

Link to comment
Share on other sites

I have solved the touchpad with a kext for older laptops.

 

Tried enabling XhciPortLimit but the webcam is still not recognized. Using USBMap I identified the port to which the fingerprint sensor is attached, and the one to which the Bluetooth is connected, but found none saying anything related to the webcam. Any other ideas to explore?

 

Regarding the battery parching process, I went through Rehabman's guide but didn't really understand the process much. I guess I'll have to accept I won't be able to know how much battery is left.
 

Thank you very much for all the help.

I tried disabling the webcam with the keyboard shortcut and enabling it back, and after I enabled it back, a notification showed on the top right corner of the screen. You can see it attached.
Does this trigger any ideas?

 

Screen Shot 2021-08-27 at 20.24.32.png

Link to comment
Share on other sites

Thank you very much Jake!
Is there any other change besides replacing the three SSDTs I had with the DSDT.aml file? If only that, I can change the ACPI - Add part of the config.plist file for making it work. Otherwise, I'll post my current EFI (with trackpad working) for you to help me.

Thanks,

    elBuey.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...