Jump to content

E5470 with BigSur 11.3 at 90% ​​​​​​​​​​​​​​with problems in the webcam, hdmi, wifi and airdrop


El_Makuaz
 Share

Recommended Posts

Good afternoon again greetings from Mexico. I have finally finished the Dell Latittude E5470 with BigSur 11.3 with OpenCore updated to 0.7.2

 

At the moment these are the specifications:
✅CPU: Quad core Intel i5-xxxx 2.6GHz
✅ RAM: 32GB DDR4-2133
✅ Graphics: integrated Intel HD 520
✅ Storage: 1TB M.2 and 2TB SSDs

 

85014255_CapturadePantalla2021-08-27ala(s)13_02_59.png.dad1deb83746f1e789175ed9fda3f513.png

 

I have solved many problems thanks to the good 🤗 @Jake Lo 🤗who once helped me to solve a battery and drain problem.

I have mounted the m2 SSD and SDD this way in case someone needs to do it on this machine:

👇
273983781_CapturadePantalla2021-08-27ala(s)13_11_52.png.b7ea95ac2aefc4b739b1a66736701889.png

 

1954960057_WhatsAppImage2021-06-25at16_14_31.thumb.jpeg.1c606618a11a902b368911213386ea17.jpeg

 

1809323013_WhatsAppImage2021-06-25at16_23_38.thumb.jpeg.7bc798efc90fa561f16d1b1b8012c753.jpeg

 

You completely disassemble the SSD and connect, you can use double-sided tape to join them and they do not move

 

234136564_WhatsAppImage2021-06-25at17_37_40.jpeg.625217b386129e2a6aa97ed6a35ab89a.jpeg

 

1967522497_WhatsAppImage2021-07-06at10_35_22.thumb.jpeg.822c444e49b41337266ead9f50ce2328.jpeg

 

Currently I find myself with 3 problems hoping they can help me solve it.

⭕1.-The integrated web camera does not work I have read that it works for some but I cannot make it work.

⭕2.-I'm browsing quite slow since I updated to OpenCore 0.7.2 (from 0.7.1 to 0.7.2), and I found the surprise that in HackinTool I have the same wifi kext twice and I can't find how to eliminate it, MI THEORY IS THAT BY HAVING IT DOUBLE I AM NAVIGATING VERY SLOWLY even connected to the 5hgz network of my fiber optic modem.

766744113_CapturadePantalla2021-08-27ala(s)14_10_02.thumb.png.e6115128207c392930abf0382c29c40a.png

 

575833092_CapturadePantalla2021-08-27ala(s)13_38_32.thumb.png.2f3c0728b233659cb8fa3f9ce87318b5.png


⭕3.-When connecting the hdmi cable the computer turns black and the video does not pass to the external monitor, I have tried everything to close the lid, connect and disconnect the hdmi and only if I run with luck it works and if not I can not do works correctly.

⭕4.-The AirDrop still does not work, which I understand is linked to apple services which apparently I have working at a hundred.


Any help would be very much appreciated! I've been working with this team for weeks and the performance is excellent! greetings little brothers !!
I am attaching my record in case someone would do me a favor to give you a revised one that does not interfere with your valuable time

** Note If someone needs my configuration and has the same equipment, I can also contribute to the community!

 

hackingt0sh.ioreg

Link to comment
Share on other sites

  • Moderators

I checked some E5470 IOreg from other user and the Webcam is detected under XHC/HS11

Check your BIOS, make sure it's enabled.

For the external HDMI display, for this model when you plug in HDMI or DP display, the internal LCD goes blank. Just close the LCD for a few second until the external becomes the primary display.

Then open the LCD, both display will come on. You just need to place system to sleep once before attaching external display, then you won't have this issue. You could try EDID to fix it. 

Link to comment
Share on other sites

Thank you! @Jake Lolook brother, restart the computer and when entering the bios it is fully enabled and still does not work.

104719119_WhatsAppImage2021-08-27at17_41_52.thumb.jpeg.9f75cc698abf9e692ad3df9aac87ebd9.jpeg


Do you notice anything unusual about the Wi-Fi connection in the ioreg bro?

Edited by Hervé
Removed unnecessary quoting of preceding post
Link to comment
Share on other sites

  • Moderators

Camera not showing up in IOReg so you'll probably need to re-do the USBPort kext. Use Hackintool.app

As for wifi, well you have an Intel, it's fully supported. You could try opting for Itlwm.kext with Heliport.app. Might work better than with AirportItlwm.kext

 

Link to comment
Share on other sites

thank you very much good morning! a question how do i map usb ports with hackintool? since i have never mapped them when i installed bigsur i didn't need to.

On the Wi-Fi side, download the helli port probare app

Edited by Hervé
Removed unnecessary quoting of preceding post
Link to comment
Share on other sites

thanks I was following the guide mentioned above and after applying these changes to map the usb I have the following error, this is exactly what I did

 

1.-Mount the EFI partition

 

2.- In the EFI> EFI> OC> Kexts folder, delete ANY OTHER kext that referred to the usb map or the dell map in general and place only the USBInjectAll.kext (obviously support the previous one that I had in my case was called: USBPorts_E5470.kext)

 

3.-After I opened my config.plist with ProperTree, take a snapshot with the cmd + R keys

 

4.-Later in ProperTree I scrolled down to verify that the USBInjectAll.kext was in Kernel.

 

5.-Then check that Kernel> Quirks is XhciPortLimit and set it to True.

 

6.-Save the changes to the config.plist and exit ProperTree.

 

Restart the computer but when trying to enter this screen appears

 

1679772960_WhatsAppImage2021-08-30at11_34_47.thumb.jpeg.3b46a6b09555ff3b8159ed6f58c422a6.jpeg

 

 

Did I do something wrong? I hope you could help me to configure and continue with my port mapping please: /

Link to comment
Share on other sites

thanks brother for answering, I did not choose openshell to restart, just restart to start with part 2 to map and go directly there, restart several times by typing exit; I even pressed f12 to directly choose the boot where it loaded well but nothing else does not enter the system.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...