Jump to content

E7450: Monterey Install Issue (wifi card specif.), Post-Install, Multi-boot & Clone questions.


Justin Wallis
 Share

Recommended Posts

So. First off, I'm using @Jake Lo's amazing (E7450_OC_0.7.5.zip) EFI's

Using both Intel Wifi, and BCM94 (just changing config files)..

 

Further Details:

Latitude E7450 I5/I7's, 32GB ram, 500GB/1TB SSD 

macOS 12.2.1

OC Configurator 2.57.0.0. (Every time i tried using the OC configurator that specifically was for 0.7.5.0, it said can't open app, and some weird error, and for like 4+ different versions this was the only one that even worked, tried on multiple monterey laptops)

 

Wifi Card / Install Question:

The install works perfectly when i have the proper BCM94360NG wifi card installed:

 

BCM94360NG M.2 WiFi Card:

https://www.ebay.com/itm/For-macOS-Catalina-Wireless-Card-BCM94360NG-better-than-DW1560-BT4-0-2-4-5G-Card/254539318793

 

But, if i don't have any wi-fi card installed, the Monterey Installer sticks at 15 minutes, and doesn't seem to proceed.

 

I understand that i should  rename and use "Config-IntelWifi" when using the original intel wifi card, Does that mean that the original Intel Cards works with Wifi/BT?  If that's the case, i can use all these old intel wifi cards and stop buying the 45$ one! (trying out now).

 

Also, this is the only thing i need to switch (intel/non intel config file) if there is different or no cards present? If i were cloning with Carbon Copy Clone.

 

 

 

My Post Install Question:

Is there a reason why it is hard to find explicit instructions on how to Post-Install? Specifically referring to "Update / Change in Config.plist under PlatformID->Generic: MLB, ROM, SystemSerialNumber and SystemUUID".  I have been hackintoshing for over a decade and i still find it difficult to do (for a couple reasons listed below), and would like to see a proper tutorial somewhere.   Is it because people are worried about the legal implications of further tutorializing the process?  I'm honestly interested if this is the case or not.  I plan on making a tutorial of the process, and would like to know if i should blur out or not do certain parts on video, or just not make public that part at all.

 

The GenSMBIOS updates the Board Serial and smUUID very well it seems (It stopped generating or populating System Serial or ROM, as did the configurator's generate buttons). So, I then go to System Preferences > Network > Ethernet > Advanced > Hardware to get the Mac ID, and this # goes in the ROM category.  Or can i use the # i get in SMBios's "List Current SMBIOS" and use that # as well (which should be same # i guess, need to check). And for system serial # i just replace the last 5 or so digits (of the one given to me in the config.plst) with random characters. Also, checking this new random # on mac's validity check always returns the same thing (something like "we are unable to check with our servers at this time"), which pretty much means, it's not in use, and i'm good to go (sign in to icloud/messenger etc). And theeennn i can allow internet connection, and not before that so "trustd" doesn't pull the old info before it's updated (or is it "accountsd" that does that, i forgot).

 

Is these steps correct? I have found very little on the subject for some reason, i had to pull from posts about it all over the internet, but not found a good written post-install tutorial. If there is one, can somebody link it?

 

Also, more simply, why it is difficult: The generate button on opencore Configurator for system serial does nothing anymore, and gensmbios does not anymmore update or populate system serial or ROM. Which is also MacID (ROM)?

 

 

Multi-boot question: 

I have also not found much about this topic besides a couple reddit and forum posts, that also did not go into any details. 

 

I am wondering, Is this a good way to do it (i want mac, windows, linux)?

 

Install monterey with this process, then partition the drive with a Exfat for the Linux, install the linux, do same with windows, then that is it?


I will do some more researching and jump in and try

I am currently using this as a multi---boot instruction / reference:

https://dortania.github.io/OpenCore-Post-Install/multiboot/bootcamp.html#installation

https://www.reddit.com/r/hackintosh/comments/k0mv0r/basic_opencore_multiboot_instructions/

 

Does anyone have any more info, or a tutorial on the process for this so i don't waste too much of my time, as i did with finding out the correct post-install process (years of trial and error).  I'm also unfamiliar with mac's multi---boot / bootcamp, and also don't know a great deal about windows / linux when it comes to multi---booting.

 

Thank You all that have made this possible and have gotten me this far as is, i would use either chameleon or opencore, i was just told that OC was better bc some things, and also built in multi---boot.

 

Also, what about the folder entitled "MACOS" that i've seen within some EFI folders i've seen (next to boot and OC folders). I guess that is not needed anymore if using OC's efi .

 

I love you guys, and i've been slammed over and over for making stupid mistakes, and i admit i've made alot of simple stupid mistakes in my hackintoshing, but i wish that there was just more simple tutorials for the people that are not great with computers. And I understand that hackintosh is not supposed to be plug and play, and for people without patience, but at this point, with all of your hard work, I just feel like there is a way to simplify the process for the people that are not good with computers at all. 

 

My 4th Question: I'm just wondering about if i'm essentially "allowed" legally, or do you think would be safe to, on a website, sell Latitudes & Precision's with correct BIOS settings. And also and simply show people how to make installer usb, follow your instructions with EFI files, show how to install and specifically Post-install show how to change the MLB, ROM, SystemSerialNumber and SystemUUID. And not even giving away usb sticks without or with installer, just showing. And eventually showing them how to mb with linux/windows without complications, and what to do to avoid complications.  Would this be legit?  It wouldn't be considered the complete package, right, or too close to?  (Just because i chose further simplify the process and sell laptops without any OS and spell out the next steps for them).  Thanks

 

5th (& final) QuestionCloning Related Issue. (Carbon Copy Cloner doesn't return any errors, and it says "cloning successful")

- i'm using fresh installed monterey (from a usb installer), and a fully updated (6.1 (7303)) Carbon Copy Clone that i Bought from bombich

This is what it looks like (Volume not appearing in Bootloader) booting from a clone (randomly sometimes):

IMG_7647.thumb.jpeg.23a2212caef5ea3ae1d0b14a5077a2cd.jpg.d9cc340513b2ab6a9e3f72669c3ec828.jpg

 

It looks like some of the cloned drive has a incomplete or messed up APFS structure, because i don't see a system Volume or a Data Volume, just a top volume

743776019_ScreenShot2022-02-26at8_39_42PM.thumb.jpeg.574fb2d8289d42e963da143b23fbbde5.jpg.7c705eb948ed0d25480a2694fe86c603.jpg

 

But, why does this happen with 50% of cloned drives

 

This issue has been happening for years (starting with Big Sur, and now with Monterey) and i have never gotten any help from Carbon Copy Clone because they said they can't help because "opencore is 3rd party". 


Anyway, they refer to similar issue here: Some startup volumes don't appear in the Startup Disk Preference Pane  Link: https://bombich.com/kb/ccc6/macos-big-sur-known-issues 
It says:

Quote

 

"In the past, the Startup Disk Preference Pane would list all available startup volumes, including CCC backup volumes. When Apple's APFS replication utility is used to copy a Big Sur System volume (something that is now required on macOS Big Sur), however, the cloned volume will not appear in the Startup Disk Preference Pane, despite being perfectly bootable.

We reported this issue to Apple in Nov 2020 (FB8889774). Apple resolved the issue in macOS Monterey.

Workaround: To boot from the backup volume, restart your Mac while holding down the Option key, then select the backup volume in the Startup Manager. When your Mac has completed booting, you can optionally choose to set the startup disk to the current startup volume (i.e. if you want the Mac to always boot from the backup volume)."

 

 

It says "Apple resolved this issue in Monterey", but it still occurs in Opencore.

 

And, The "Workaround" they give doesn't work with opencore, and never has.

 

I've even tried their "Legacy Bootable Copy Assistant", and it seems to be producing the same results.
287685776_ScreenShot2022-02-26at10_43_11PM.thumb.jpeg.7dde07bf7e58117097320d16659573b0.jpeg

 

I'm going to message CCC/bombich and ask them again, and just refrain from saying the words opencore.

 

I will make a couple clones, and they will work fine. The next couple clones won't show up on OC's bootloader, the next couple will work fine. But seemingly, this happens in a random order, with the same clone settings (Safetynet Off), and with the same (Main) drive with nothing changed on it. I don't even know what to try (already did Reset NVRam, and took Battery/Power out to reset V-ram, which seems to help with boot sometimes in past when it gets funky). 

 

The only thing i do to the cloned drive is (after it's cloned) I Put the EFI folder in the EFI drive of the clone.     

 

I wish i could use Hackintool to Rebuild KextcCache and Repair Permissions on an external drive.  What code would i run in the terminal (using the code in the red i assume) on the cloned volume to achieve this?

1102587486_ScreenShot2022-02-26at8_07_55PM.jpeg.892a7ccfd4745cc699fd6a57fe222619.jpg.3b72020ddc136846e7d5c4d90cc52a1f.jpg

 

What is even happening anyway? is the clone messing up the APFI structure (It definitely seems so)?

 

Is the clone messing up the new EFI partition (sometimes it takes really long to move 20mb to the cloned drive's EFI folder, it's weird).

 

I have never got any answers from anyone on forums either about this problem. Has there been anyone that has had this problem, and if so, please how did you fix it? Please!! Thank you

 

(I am going to do same process on my precision 5510 eventually with Jake Lo's EFI/Tutorial for that, i just want to get this one out of way first, I'm also so excited about being able to finally all these dell wifi cards finally! Amazing it works perfectly, thanks!!)  

Link to comment
Share on other sites

  • Administrators
  • Re: Intel Wifi cards, just consult the ILTWM site where you'll find the list of compatible cards. Statements such as "the original Intel card" are totally meaningless without any reference to the exact model.
  • Questions about legality keep resurfacing every now and then. By now (2022) everything that needed to be said/written has been said/written; do as you wish, this forum certainly ain't a place to ask permission to build a Hackintosh, especially considering you've been Hackintoshing for over a decade... <_<
  • You've been a member since late 2020 so, if you've not done it yet, now is a good time to read our published rules and enlighten you on what's not allowed on the forum.
  • 'never had any trouble injecting the SMBIOS details and I've always used random values for ROM rather than the host's MAC address. The Dortania guide looks pretty clear to me in that respect. As an experienced Hackintosher (over a decade), you should have no difficulty there. The Generate buttons do work in OCC -at least for me- (or in CC to that effect), maybe you need to update the version(s) you run.
  • Chameleon is long dead, today only Clover and Opencore remain under active maintenance and development. You'd only use Chameleon for an (old) installation of an older OS X/macOS build certainly not for Monterey! As an experienced Hackintosher, you should long know this.
  • Your questions re: cloning to appear linked to a desire of yours to build Hackintosh laptops for resale. Understand that we can't assist you on this matter. This community does not provide support for commercial activities around Hackintosh. And we're not going to help you make money out of free support.
Link to comment
Share on other sites

 Share

×
×
  • Create New...