Jump to content

E6540: unable to get 2nd Internal disk detected and sign in with my Apple ID in Monterey


Recommended Posts


  1. I have the latest Monterey working fine on E6540 using OpenCore EFI but unable to get a second internal SSD to be detected once I have logged in. Disk Utility just doesn't recognise the 2nd SSD if its internal, it will detect it only via a SATA usb cable. I just need to use the 2nd internal SSD for additonal storage.
  2. Also please how can I populate / generate the serial number, etc in my config.plist properlly... so I can sign in with my Apple Id? I've tried but it keeps telling me failed to communicate with the server.


I have attached the EFI, it may help others to get E6540 to work. Thanks


Link to comment
Share on other sites

Thank you Jake, much appreciated, it works flawlessly.


I've tried my best to get the apple id working, I did some reading on OpenCore, I tried your seial and also generated new ones with GenSMBIOS and using my ROM which is the ALFA USB AWUS036AC, I used chris111 kexts to enable it and it works.

I am not sure what I am doing wrong. I put the ROM in all lower case also and removed the :  this is my mac address for that USB 11:c0:ca:22:42:16



I have attached my config to see if you can spot something wrong  


I've done it a few times, I can always see the Macbook pro registered as one of my devices on my iPhone however I keep getting this on my Mac and its not signed in yet.


Screen Shot 2022-05-15 at 10.53.06 am.png

Link to comment
Share on other sites

Jake I am just hoping you can help me please when you are free with one final thing, I just found out with my EFI above and using your patched config.plist. the integrated web cam is not working. Need it for interviews, etc.. Thank you.

Link to comment
Share on other sites

Thanks, it looks like the first config didn't have it working. I did replace the USBPorts.kext but still not working. I've updated OC to the latest v0.80 and attached the EFI. Its all working except for the web cam. Hoping it can be fixed.



Link to comment
Share on other sites

  • Moderators

Looks like SD Card reader is not working

Not sure if you Brightness control is working properly

Not sure if sleep / wake is working with the AMD graphics on


Try this config with some fixes and add SSDT* to disable the AMD discrete card


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...