Jump to content

E7450: Catalina 10.15.7 installation breaks with SIGKILL in diskarbitrationd


msc
 Share

Recommended Posts

Hi, I'd like to install Catalina on my E7450 with 256GB mSATA SSD and followed Jake Lo's OpenCore guide. I get until the progress bar "About 3 minutes remaining".

 

Then it dies in com.apple.xpc.launchd[1]:  "com.apple.diskarbitrationd.209 (Notice); Service exited due to SIGKILL | sent by diskarbitrationd[209]"

 

Before posting this here, I tried Google. Only very few hits and all are related to Big Sur, I didn't find anything for Catalina.

 

However, I found this thread "diskarbitrationd SIGKIL problem when trying to upgrade to Big Sur from Catalina #1" on github

where someone claims "It will be solved by adding SSDT-PMC.aml"

 

Sorry for the dumb question but as I am completely new to Hackintosh does this make sense and if so, how would I do that?

Link to comment
Share on other sites

  • Administrators

Please post the hardware specs of your E7450, ideally put them in signature.

Unlike NVME SSDs, there are usually no issues with SATA (or mSATA) SSDs and macOS on Hackintosh.

 

Your issues probably result from some incorrect quirks in your OC config. Which pack did you use? You probably need to stick to those with versions 0.6.x.

 

I would also suggest you check your BIOS settings and compare them with the ones I recommended for the E7250. In particular, make sure you set your E7450 in UEFI mode, that Legacy Option ROMs is set to enable and disk mode is set to AHCI. I'd also update your BIOS to latest version A24 if you're not already running it.

https://osxlatitude.com/forums/topic/12177-e7250-bios-settings/#comment-93649

 

The E7x50 is starting to age but these Broadwell/HD5500 laptops are rock solid when it comes to installing and running macOS on them and everything is supported. Once you've checked your BIOS settings, you may want to give this Clover guide a try. Or Jake's own Clover guide too.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...