Jump to content

Intel AC 8260: total loss of Bluetooth

Recommended Posts

Hi there, need some help.

System Info:

  • Dell latitude E5470 i5 6440HQ
  • ram 16gb
  • Graphics intel HD 530
  • network card: intel dual band AC 8260 w/bluetooth

So I have macOS Monterey installed; using it for a while now. Bluetooth wasn't working so i wanting to fix that and I used BlueToolFix and IntelbluetoothFirmware kexts. It worked actually pretty but after a few hours, I restarted my pc and bluetooth stopped working again. I did some twikling again and added IntelBluetoothPatcher kext after which bluetooth started working again. After restarting the PC, bluetooth stopped working again.


Now the problem is that it's just not working in Monterey, it's not working in Windows either; the Bluetooth device is not even detected. I have tried everything I could so far and last resort is asking for help here. I'd appreciate if anyone can help me fix this.


I am willing to provide more info if you need any. Thanks


you can download my EFI from above can't upload here because of size limit:

Link to comment
Share on other sites

  • Administrators

-> Thread moved to relevant hardware support section; this is not a thread about hardware information. Please make every effort to post in the appropriate forum sections and to use punctuation, not just post in a single extended sequence of words! This is totally unreadable and such posts/threads be deleted without prior notice in the event of re-occurence.


Assuming you've followed all the necessary recommendations posted at ITLWM, you can always try and re-apply the Windows driver for the card in the hope that it'll reload the firmware onto the card if that's what's gone sideways.


But you may have to consider that the card is either suffering from a bad connection (try and clean the cards connector and the slot) or simply got defective (it happens). Check if the Bluetooth module is seen or not in SysInfo->Hardware->USB. If it's not, as per in Windows, you have a hardware-related issue. it's probably not the case but do check that Bluetooth did not get somehow disabled in BIOS settings.

Link to comment
Share on other sites

these are the things i have tried so far
- clean the card slot reseated it twice
- installed drivers in windows again

- checked bios card is not disabled there and it is detected that BT is installed in BIOS
now wierd thing is i am temporaraly using a external BT dongle and the same thing happen to it to after sitting idle for over night the dongle stopped working in mac os and windows also after unplugging and replugging it into a different slot it started working again now this also happend when i tried to put the laptop to sleep do you think it has something to do with USB power or something

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...