Jump to content

Dell Optiplex 745 - Ultra small form factor


mcginkel
 Share

Recommended Posts

Yesterday I successfully got LION to work on an optiplex 745. Not without issues, but most functions are running  now.

 

I have the Ultra Small Form Factor.

I downloaded the bootpack for a Optiplex 745, LION installation. It did not recognize the internal disks as they are not ACHI compatible in the BIOS even with the latest BIOS updates.
I addded the IOATAFamily.kext to the Extra\Extentions folder on the usb stick, put the BIOS in legacy mode and was sucesfull in installing LION.

Booting did not work, I needed the option to Ignores kext caches during bootup, after booting I placed the -f flag in to chameleon config.

When I applied the EDP package I lost the disk as the IOATA familly kext is no longer present. I have tried to report an error on the site, but all forms seem to be disabled for maintainance. I installed the Extra folder from the usb stick to revert. I assume that that also reverted all other EDP installation/actions. Is that correct ?

 

Now I did not have any sound, but networking is working. Graphics is a internal IntelGMA 3000. Resolution was only 1024*768. Not enough.... I changed the Graphics Mode to 1280*1024*8 in the org.chameleon.Boot.plist, and added the AppleIntelGMA950.kext to the extra folder.

 

Questions I have:

  • Can you make the EDP more robust by adding the IOATAfamily and IntelGMA950 kext to the configuration for a optiplex 745 USFF ?
  • What changes do I have to make to get the sound working? or will that be fixed automaticly by the EDP ?
  • Is the option to ignore the kext caches during bootup normal for the 745?
  • Can anyone recommend an USB Wifi adapter that will work with this configuration?

 

Thanks a lot for all the information on the site so far.

 

Kees

Link to comment
Share on other sites

As for a USB Wifi device...

 

I have several Belkin F5D7050 version 3 cards that has the RaLink RT2500 chipset. It works with the RaLink configuration utility just fine. Does not show as AirPort, however works great.

 

I also have a few Buffalo WLI-U2-125S cards that have the Broadcom 4320 chipset. They work natively in OS X. Show up as AirPort, and work great.

 

So, any USB Wifi cards that are Broadcom based should work.

  • Like 1
Link to comment
Share on other sites

@bronxteck: Yes that works well I ran EDP, copied the IOATAFamily.ext to E/E and ran myFix again.

I also removed the -v flag from boot options in  org.chameleon.Boot.plist, changed the Graphics Mode to 1280*1024*8 and restarted. Working properly. I did not need the AppleIntelGMA950.kext. It worked without.

 

@bobdamnit: Thanks for the hint. I ordered an USBWifi thingie and will try it as soon as it arrives.

 

So what is next? Sleep is not working, but i haven't spend time looking at the forums how to fix that.

Secondly: there is an aple update waiting to update to 10.7.5.......... shall I just run it and see if I am lucky and it does not break anything? or spend some time digging on the forums to see if it is safe to update.

 

New Question: Can you add a kext in the extra folder (IOATAetc) even when you do not need it? So if you would change the bootpack would it have side effects for other users who have 745's with AHCI support?

Link to comment
Share on other sites

 Share

×
×
  • Create New...