Jump to content

E6220 and built-in microphone


Recommended Posts



A few years ago I bought E6220 with the intention of installing macOS, but somehow I gave up and used it with Windows. Recently, the laptop "was no longer needed", so I came back to the idea of installing macOS :)


I read the instructions provided in @Hervé E6220 guide and started with High Sierra. Everything went smoothly, even Intel Wi-Fi started working (from AirportItlwm.kext) and I decided to update to Catalina. Here I needed to think through the instructions a little bit. As I'm a novice, I didn't really know what I was doing and something like this worked:

- I updated Clover first.
- Then I updated the files from the packages prepared by @Hervé, i.e. I overwrote what I had installing High Sierra with files for Mojave and then with files for Catalina.
- I restarted the system to check if it works.
- After reboot, I ran DosDude1's Patcher and installed 10.15.7.


It generally works, but I noticed 2 problems:
1) Some applications do not work, e.g. Chrome. But I think it is not a problem of Hackintosh, but of the Patcher itself and the computer's incompatibility with Catalina requirements (no compatibility with Metal): https://github.com/dosdude1/macos-catalina-patcher/issues/237. Am I right?
2) The "built-in microphone" doesn't work for me (I use the Polish version of the system and I translated it from Polish to English). It's about the microphone next to the camera. It seems to be detected (I can see the built-in microphone in System Preferences -> Sound), but when I test it, it doesn't work. Should it work? Am I missing something in the system or have I configured something incorrectly?


I also had to change AirportItlwm.kext to itlwm.kext + HeliPort. Is it again problem with Patcher or with Catalina itself?



Link to comment
Share on other sites

  • Administrators

Hi, it's old stuff now and I sold my E6220 a long time ago now but to answer your questions:

  1. yes, running Catalina with dosdude1's patcher is not without limitation and/or bugs. Today, given the development of the OpenCore Legacy Patcher since the Catalina and dosdude1's patcher days, you may want to consider a more recent macOS version (Big Sur and later) with OpenCore and OCLP given that this patcher is a lot more sophisticated and efficient than all tools that preceded it. Afaik, it fully supports the E6220 SMBIOS target model, i.e. MacBookPro8,1 with HD3000 graphics. You may check the Release Notes of all recent versions on the OCLP GitHub repo.
  2. no reason why the built-in microphone would not work; check that it's not disabled in your BIOS settings.
Link to comment
Share on other sites

2. I will check the BIOS and I will put back the SSD with Windows to be sure if the built-in microphone works properly :)


1. OCLP will be quite a challenge for me, but I hope to have some fun too. If it works, I'll describe it for others, and if not, that's fine. I'll probably have a few questions ;) First, these:


If I understand correctly: OCLP creates a bootable USB. If the boot from USB is successful, I will be able to install the system. If it installs correctly, then I should patch the working system?

Link to comment
Share on other sites

  • Administrators

You can either:

  • install macOS using a regular OpenCore method knowing that:
    • you'll need to proceed with a config using the SMBIOS of a supported model
    • you won't initially have graphics acceleration
  • then revert to MBP8,1 SMBIOS, boot with -no_compat_check boot arg and manually proceed with OCLP patching with carefully selected parameters (OCLP is not made for Hackintosh but for real Macs)


  • you can indeed create a USB installer through the OCLP patcher and everything will be ready from the onset (still with carefully selected parameters).
Link to comment
Share on other sites

For now, the E6220 is my only Mac, so I have to make changes carefully ;) But I'm waiting for E7270. With the working second one I will try to upgrade E6220 to newer MacOS :)


Using OCLP I prepered USB installer with Monterey for MacBookPro8,1, but I can't boot with it. It is for UEFI booting, but E6220 has problem with UEFI. I probably need to use Clover + OCLP?


About the main problem from this topic: Camera microphone started working. Automagically. After restart. I do not know where the problem was :/


And at the end:


I found the way to run Chrome/Opera/Edge/Vivaldi/Brave on my Hackintosh with Catalina patched by DosDude1's Patcher. As I understood THIS IS VERY INSECURE, so if anyone tries to use it, be warned.


Generally the source of the problem is here:


  Reason: no suitable image found.  Did find:
    file system sandbox blocked open() of '/System/Library/Frameworks/SafariServices.framework/Versions/A/SafariServices'


or here, from logs using command log show --start '2023-12-30 16:00:00' --predicate '((processID == 0) AND (senderImagePath CONTAINS "/Sandbox")) OR (subsystem == "com.apple.sandbox.reporting")':


Violation:       deny(1) file-read-data /Library/Apple/System/Library/Frameworks/SafariServices.framework/Versions/A/SafariServices


The problem is connected with application sandboxing, which is made to increase security. These apps should work, but the Patcher is probably making some changes to the system causing their signatures to not be accepted. I don't know how to change sandbox rules, so the only way I found is to completly disable sandboxing of these apps.


How to check if the Sandbox is the problem? Run from terminal for example:


/Applications/Opera.app/Contents/MacOS/Opera --no-sandbox


If works then you need a way to start it from the Launcher. I've created apps with Automator:

  • start the Automator
  • create File -> New -> Application
  • add Run AppleScript
  • write the script (look below)
  • save it in Applications foolder

The script can look like this:


on run {input, parameters}
    (do shell script "open -a '/Applications/Google Chrome.app' --args --no-sandbox")
    return input
end run


or like this:


on run {input, parameters}
    (do shell script "open -b com.operasoftware.Opera --args --no-sandbox")
    return input
end run

Link to comment
Share on other sites

  • Administrators

With BIOS in UEFI mode, you can boot macOS on the E6220 once it has been installed but you cannot boot a USB installer. I think I had stated that in my old E6220 guide and/or the E6220 BIOS settings thread. Of course, you can always consider creating your installer on a small partition of your internal SATA disk. That should work but I can't remember if I ever tried that.

Link to comment
Share on other sites

Creating a working Hackintosh with @Hervé instructions is simple (Thanks!), but modifying it requires reading "a few" details ;)


It took me some time, but I finally realized that OCLP is not for me, but for owners of real Macs... although @Hervé already wrote it to me :)


I read a little about OpenCore and even understood some of what can be found on the Dortania website ;)


I will try to run my Hackintosh from OpenCore. If I understand correctly, if I manage to boot the computer from a pendrive with correctly configured OpenCore, it should then be possible to run the Catalina installation already existing on the disk?


However, when reading the documentation for OC and OCLP, there is something that I do not understand :( This applies to both my Dell and the original MacBookPro8.1.

Once I manage to install Big Sur or Monterey or something newer on such equipment, I then run OCLP and the option Post-Install Root Patch. This part is simple.

But the question that bothers me: How to properly install Monterey? I already tried to run the installer and saw a message that my hardware is incompatible. I have to change the SMBIOS to one compatible with Monterey during the installation and, after installing it, set the one that suits my hardware? Is there another way that I haven't found yet? 

Link to comment
Share on other sites

  • Administrators

With a regular/standard installation, yes you need to use the SMBIOS of a supported Mac model for the target macOS version. You may then change to the SMBIOS that normally suits your laptop (here MBP8,1) and boot with boot arg -no_compat_check.

OCLP takes care of that on the other hand.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...